[mac] New Search UI doesn't look right

RESOLVED FIXED in Firefox 2

Status

()

Firefox
Search
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: marcia, Assigned: Jay Goldman)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
PowerPC
Mac OS X
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change])

Attachments

(4 attachments, 2 obsolete attachments)

Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b1) Gecko/20060814 BonEcho/2.0b1.

The new quicksearch UI doesn't look right to me.  They changed the behavior so when you click on the favicon it turns into a hover state, but the outline of that field is very faint on my PPC Mac. To me it also looks jarring to not have the outline present all the time. Screenshots coming.
Created attachment 233609 [details]
Screenshot of today's build, with favicon area in hover state.
Created attachment 233612 [details]
Screenshot of 080906 build, with quicksearch bar all attached.
Summary: New Quicksearch UI doesn't look right → [mac] New Quicksearch UI doesn't look right
Component: Toolbars → Search
QA Contact: toolbars → search

Comment 3

11 years ago
I agree, the images don't look like they're attached to the searchbar very well.  Perhaps the art could be adjusted to strengthen the connection between the two?
nominating to get this on the radar.
Flags: blocking-firefox2?
Target Milestone: --- → Firefox 2 beta2

Comment 5

11 years ago
Created attachment 233884 [details]
Mockup of possible changes

Here's a mockup of possible changes, with two options.  

Both options add a beveled border on the right and left ends of the text area (achieved by reverse bevels on the button images), to match the ones on the top and bottom and the one at the end of the urlbar.  

On one option, the second change is a slight darkening of the rounded edges on all three buttons, so they meet the dark top borders more smoothly but still look convex to fit with the other toolbar buttons.  (They're not very smoothly darkened in my version, because I'm not a very skilled artist.)

On the other, the rounded edges are also darkened, but here they're flipped vertically so they merge with the borders and look firmly attached to the text boxes.
(Assignee)

Comment 6

11 years ago
(In reply to comment #5)

> On one option, the second change is a slight darkening of the rounded edges on
> all three buttons, so they meet the dark top borders more smoothly but still
> look convex to fit with the other toolbar buttons.

This is definitely my preferred of the three - we didn't intend to have the buttons look like they were inside the field, which the third mockup looks like to me. If that's what everyone else agrees to, I can whip up smoother graphics.

(I think you're an excellent artist Pam!)
Option #2 is great, I'd been wondering about this myself (was gonna give it another day to see if I got used to it) and I agree with Jay; these mockups are great!

Updated

11 years ago
Assignee: nobody → jgoldman
Flags: blocking-firefox2? → blocking-firefox2+
Whiteboard: [Fx2 theme change]
Target Milestone: Firefox 2 beta2 → Firefox 2
*** Bug 348758 has been marked as a duplicate of this bug. ***
I also agree that Option 2 is the best one of the choices. Thanks for the work Pam.

Comment 10

11 years ago
all applications on mac have one concrete style. the same should use firefox. like it was. would look more native

Updated

11 years ago
Whiteboard: [Fx2 theme change] → [Fx2 theme change][artwork needed]
(Assignee)

Comment 11

11 years ago
Created attachment 236754 [details]
Pintstripe end cap replacement images

This should be what we're looking for - Pam: let me know if you need anything else.

Comment 12

11 years ago
Created attachment 237142 [details]
Screenshots showing bevels

Thanks, Jay, those are great.  I did try one thing, adding bevels to the inner edges of the endcaps so that the searchbar text area is fully beveled the same way the urlbar is.  (The urlbar does that with CSS, but the searchbar can't, so this little hack is needed.)

The three screenshots in this image show the current build, a build with Jay's new images, and a build with images that include the bevels.  Beltzner, if you'll make a call, I'll check 'em in.
Attachment #233884 - Attachment is obsolete: true
Attachment #237142 - Flags: ui-review?(beltzner)
(Assignee)

Comment 13

11 years ago
Pam - we're going to revisit the images again to see if we can be more Mac OS X like so I would say hold off on this for a bit before we commit anything. Thanks!
Comment on attachment 237142 [details]
Screenshots showing bevels

Pam: let's go with "beveled"; as Jay said, we're looking at removing the 3d effect on the endcaps, but if we don't manage to get to that, what you're showing here is a clear improvement over the "before" image.

thanks!
Attachment #237142 - Flags: ui-review?(beltzner) → ui-review+

Comment 15

11 years ago
Created attachment 237260 [details]
Images as landed

Landing new images on 1.8.1 branch:

Go.png from attachment 236754 [details]
Search-go.png from its Search.png, plus bevels
Search-provider-bkgnd.png from its image, plus bevels
Attachment #236754 - Attachment is obsolete: true
Depends on: 351937

Comment 16

11 years ago
regression 351937

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Summary: [mac] New Quicksearch UI doesn't look right → [mac] New Search UI doesn't look right
Whiteboard: [Fx2 theme change][artwork needed] → [Fx2 theme change]
Depends on: 351993
You need to log in before you can comment on or make changes to this bug.