Add warning to "id" attribute in other than "xml" namespace

RESOLVED WONTFIX

Status

Other Applications
DOM Inspector
RESOLVED WONTFIX
12 years ago
6 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The warning could be an exclamation mark with a more descriptive mouseover. 
Many code is broken because of missing the "xml:" bit, this feature could help fix it

Reproducible: Always
we don't support xml:id do we?
(Reporter)

Comment 2

12 years ago
It's true that we don't support xml:id yet, but i'm guessing this will change as you can't access elements in a foreign namespace through document.getElementById now
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.