Closed Bug 348767 Opened 13 years ago Closed 13 years ago

misleading error message when profiles.ini points to non-existing profile path

Categories

(Thunderbird :: Account Manager, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 278860

People

(Reporter: torbjorn.sund, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla Thunderbird version 1.5.0.5 (20060815)

When the profiles.ini contains an absolute path with a non-existing drive letter, Thunderbird issues a completely wrong error message.



Reproducible: Always

Steps to Reproduce:
1. Set an absolute path in profiles.ini that contains a drive letter
2. Disconnect the drive
3. Start Thunderbird
4. Misleading error message is issued. Thunderbird exits.
5. Reconnect the drive
6. Restart Thunderbird
7. Functions normally

Actual Results:  
Misleading error message "Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Thunderbird process, or restart your system." 

Expected Results:  
An appropriate error message, e.g. "Path [wrong path] to mail profile folder is not accessible. Please correct your profiles.ini, or reattach any disconnected network drive."

My profiles.ini:
---------------------
[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=Profiles/anrsh13h.default

[Profile1]
Name=tsund
IsRelative=0
Path=t:\Mail\Thunderbird\profil.tsund
Default=1
--------------------
confirming - though I think this is a profile manager bug, not a TB bug per se.
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 278860 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.