[mac] Handle old components on upgrade ("surgical upgrade")

VERIFIED WONTFIX

Status

SeaMonkey
Installer
P2
normal
VERIFIED WONTFIX
19 years ago
14 years ago

People

(Reporter: Samir Gehani, Assigned: Syd Logan)

Tracking

Trunk
Future
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpiprd])

(Reporter)

Description

19 years ago
Mac version of bug 31821.
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Reporter)

Updated

18 years ago
Depends on: 37348

Comment 1

18 years ago
pr2 feature
Keywords: nsbeta2

Comment 2

18 years ago
Putting on [nsbeta2+][5/16] radar.  This is a feature MUST complete work by 
05/16 or we may pull this feature for PR2.
Whiteboard: [nsbeta2+][5/16]

Comment 3

18 years ago
*** Bug 32572 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

18 years ago
Since we are going for blind deletion rather than surgical upgrade this is not 
going to happen in PR2.  Moving to M18.
Target Milestone: M16 → M20

Comment 5

18 years ago
Agreed.  Missed Beta2 train. 
Whiteboard: [nsbeta2+][5/16] → [nsbeta2-]

Comment 6

18 years ago
updating mac mozilla installer QA contact to me
QA Contact: gbush → asa

Comment 7

18 years ago
Do we intend to do this by FCS or should we future+helpwanted, or should we 
assign this to someone to write a spec to describe what moz should do?
(Reporter)

Comment 8

18 years ago
Netscape doesn't intend to do this for the Netscape 6 RTM.  If mozilla's RTM is 
later this may happen.  Or it may happen for the next release of Netscape 6 
which implies that it'll have to happen for mozilla first.
(Reporter)

Updated

18 years ago
Priority: P3 → P2
Changing obsolete M20+ milestones to closest equivalent, "Future"
Target Milestone: M20 → Future
Bring on nsbeta1 radar for reconsideration. part of surgical upgrade task.
Keywords: nsbeta2 → nsbeta1
Whiteboard: [nsbeta2-]
Target Milestone: Future → ---
Whiteboard: [xpiprd]
Moz 0.8 tasks
Target Milestone: --- → mozilla0.8
(Reporter)

Updated

18 years ago
Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Updated

18 years ago
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla0.9 → ---
Argh -- how did this get minused? We will have upgrade nightmares if we allow 
people to skip updating old components. Or is the Mac still "nuke from orbit"?
Keywords: nsbeta1- → nsbeta1+
(Reporter)

Comment 13

18 years ago
The Mac is still nuke from orbit.  
(Reporter)

Comment 14

18 years ago
Moving back to nsbate1- (this got triaged early on) since we have a strategy in
place and don't have the cycles.

Added helpwanted keyword.
Keywords: nsbeta1+ → helpwanted, nsbeta1-

Comment 15

17 years ago
Syd,
This looks like 'surgical upgrade' bug- not sure if this can be done in MachV - 
but am changing assignment and myself to QA contact so we can monitor
Assignee: sgehani → syd
Status: ASSIGNED → NEW
QA Contact: asa → gbush
(Assignee)

Updated

17 years ago
Keywords: nsbeta1
(Assignee)

Updated

17 years ago
Keywords: nsbeta1-
(Assignee)

Updated

17 years ago
Keywords: nsbeta1+
Target Milestone: --- → mozilla0.9.8
(Assignee)

Updated

17 years ago
Severity: normal → enhancement
Keywords: nsbeta1, nsbeta1+
Target Milestone: mozilla0.9.8 → Future
*** Bug 114935 has been marked as a duplicate of this bug. ***
*** Bug 102189 has been marked as a duplicate of this bug. ***
Modifying summary so we don't keep losing these old dupes.

From bug 102189:

Right now the Mac installer blows away everything before installing.  Need to
emulate the Windows installer behavior of selectively removing obsolete files. 

Note: Bug #102177 parallels this bug for Linux.  

Both of these bugs are important to nseneterprise because it is very important
that Time Warner be able to upgrade seemlessly from 6.2 to 6.3.  Greg indicates
that Mac support is much more important than linux in this regard.
Severity: enhancement → normal
No longer depends on: 37348
Summary: [feature] Handle already-installed components on upgrade → [mac] Handle old components on upgrade ("surgical upgrade")

Updated

16 years ago
Blocks: 114933

Updated

16 years ago
Keywords: nsbeta1- → nsbeta1

Comment 19

16 years ago
removing nsbeta1-, Mac Installer for Buffy

Comment 20

16 years ago
removing nomination for Buffy- 
Keywords: nsbeta1

Comment 21

16 years ago
*** Bug 147429 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
Quoth Steve Dagley: "The Mac installer code was never Carbonized and there is no
intention to ever change that."

http://groups.google.com/groups?threadm=yahoo_com-77F6E8.09344011022003%40h-204-29-187-156.netscape.com
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: helpwanted
Resolution: --- → WONTFIX

Comment 23

16 years ago
per comment above
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.