A hidden input fields value is being changed on submit of a page.

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: srichardson, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

I have a html page with the following hidden input. 

<input type="hidden" id="id" value="&#125;=4&gt;&#192;&#204;8!"/>
(The value element before being made html safe is }=4>ÀÌ8! )

When I submit the page in Firefox the Id value becomes }=4>ÀÌ8!
Using Internet Explorer is fine and this issue does not occur

I use the Id value to update an object in our product but because Firefox changes this Id we can never find the object and threfore we cannot use Firefox with out product. This is very frustrating.

Reproducible: Always

Steps to Reproduce:
1.Place the following html into a page <input type="hidden" id="id" value="&#125;=4&gt;&#192;&#204;8!"/>

2. Submit the page and check the value of this ID field - this has changed from }=4>ÀÌ8! to }=4>ÀÌ8!. 



Actual Results:  
When I submit the page in Firefox the Id value becomes }=4>ÀÌ8!

Expected Results:  
When I submit the page in Firefox the Id value should be }=4>ÀÌ8!

When the html page is submitted it goes through to a ASP page which simply forwards the Request object onto our product. The ASP page does not modify the request in any way but just simply forwards it on. It is within the request object that I notice the Id value has changed - but only in Firefox!!
(Reporter)

Updated

12 years ago
Summary: Hidden input fields value being changed on submit of a page. → A hidden input fields value is being changed on submit of a page.
I assume there's no way we can see the actual page in action, since you didn't include a URL. Can you attach a copy of the HTML (or even better, a minimal testcase, with just enough to get what you want from IE, and not from us)? And, not that I've learned to distrust MS products, but since you mentioned ASP, could you verify that the same HTML is served to both IE and us?

Since À is the usual result of UTF-8 being treated as Win-1252, I'd guess Firefox is detecting the page as being in UTF-8 and encoding the form data accordingly, while your ASP is expecting Win-1252, and getting it from IE, but without seeing the page it's hard to say why, or whether we're at fault.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.8 Branch

Comment 2

12 years ago
Stuart, 
Phil is correct. In order to investigate your issue and reproduce the problem, we would need
- some kind of minimal, simplified testcase (1). Best would be to attach it to this bugfile with the "Create a New Attachment" link. A simplified testcase helps

or

- provide an URL where we can examine the code of the page

Also, can you specify the version of IE that you're using?

--
(1) What is a Simplified Test Case, and How Do I Make One?
http://www.mozilla.org/newlayout/bugathon.html#testcase

Thank you for your understanding here. Gérard
No testcase or example, nothing we can do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.