unable to modify/delete event if title is empty (untitled)

VERIFIED WORKSFORME

Status

Calendar
Calendar Views
VERIFIED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060816 Calendar/0.3a2+

I created event with emtpy title and had problem widh deleting it

Reproducible: Always

Steps to Reproduce:
1. create evenet
2. click twice on event to modify title (from main view)
   -> title is selected
3. press delete to delete title
4. click out of event to accept modification
   -> event has no title (1st error)
5. from context menu - delete event
   -> event is still visible however you can not delete it second time because menu is disabled (see screenshot) (2nd error)

Actual Results:  
error console:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calIIcalProperty.propertyName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Damian/Pulpit/sunbird/components/calICSCalendar.js :: anonymous :: line 395"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Damian/Pulpit/sunbird/components/calICSCalendar.js
Line: 395

Expected Results:  
if title is empty recover previous title

todo: need to check if there is any more possibility to create event with empty title (untitled)
(Reporter)

Updated

12 years ago
Flags: blocking0.3?
Version: unspecified → Trunk
(Reporter)

Comment 1

12 years ago
Created attachment 234059 [details]
delete bar is disabled but event is still visible
Using Sunbird/0.3a2+ (2006081512) with clean profile and day/week/multiweek/month view + ics/storage provider -> no error.

Using Sunbird/0.3a2+ (2006081611) with clean profile and day/week/multiweek/month view + ics provider -> no error. (storage provider not testable due to bug 348859).

After step 4 the event shows up as 'Untitled' and after step 5 event is deleted.
(Reporter)

Comment 3

12 years ago
can not reproduce error with clean profile, however can create event without title (like above) if you try to do it via event dialog OK button is disabled when title  is empty -no consequence
Severity: major → normal
Flags: blocking0.3?

Comment 4

12 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061027 Calendar/0.4a1 works for me

>    -> event has no title (1st error)
The event title changes to "untitled"- I think it's not a bug. If the title was blank it would be a bug

> 5. from context menu - delete event
>    -> event is still visible however you can not delete it second time because
> menu is disabled (see screenshot) (2nd error)
Menu is enabled so it's possible to delete the event

> Actual Results:  
> error console:
No error in error console
With an old profile, I couldn't choose "Delete selected event". But with a clean one this is WFM. So, I mark this bug WFM after four comments stating this works with a clean profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

12 years ago
see also bug 358969
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.