removing the account that is the default account causes assertions

VERIFIED FIXED in M16

Status

P1
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: alecf)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

try this:

my first account was a pop account.
then I added a few more, an imap and a couple news accounts.
then I deleted my first account (key = account1)
exit.
start back up.

you'll get assertions like:

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x01a94870, const char * 0x01a9485c, const char
* 0x01a94824, int 96) line 191 + 13 bytes
nsMsgAccount::GetIncomingServer(nsMsgAccount * const 0x02f8cd80,
nsIMsgIncomingServer * * 0x0012e290) line 96 + 36 bytes
nsMsgAccountManager::findIdentitiesForServer(nsISupports * 0x02f8cd80, void *
0x0012e2d8) line 1459 + 47 bytes
nsSupportsArray::EnumerateForwards(nsSupportsArray * const 0x02c34710, int
(nsISupports *, void *)* 0x01a36ee0
nsMsgAccountManager::findIdentitiesForServer(nsISupports *, void *), void *
0x0012e2d8) line 357 + 20 bytes
nsMsgAccountManager::GetIdentitiesForServer(nsMsgAccountManager * const
0x02c34810, nsIMsgIncomingServer * 0x02c50f60, nsISupportsArray * * 0x0012e48c)
line 1443
XPTC_InvokeByIndex(nsISupports * 0x02c34810, unsigned int 21, unsigned int 2,
nsXPTCVariant * 0x0012e47c) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x0215c440,
nsXPCWrappedNative * 0x02c41b90, const XPCNativeMemberDescriptor * 0x02c40e98,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 1, long *
0x025ce740, long * 0x0012e62c) line 898 + 43 bytes
WrappedNative_CallMethod(JSContext * 0x0215c440, JSObject * 0x0255b180, unsigned
int 1, long * 0x025ce740, long * 0x0012e62c) line 200 + 34 bytes
js_Invoke(JSContext * 0x0215c440, unsigned int 1, unsigned int 0) line 686 + 23
bytes
js_Interpret(JSContext * 0x0215c440, long * 0x0012ef5c) line 2464 + 15 bytes
js_Invoke(JSContext * 0x0215c440, unsigned int 1, unsigned int 2) line 702 + 13
bytes
js_InternalInvoke(JSContext * 0x0215c440, JSObject * 0x0255b920, long 39730880,
unsigned int 0, unsigned int 1, long * 0x0012f0e8, long * 0x0012f094) line 775 +
19 bytes
JS_CallFunctionValue(JSContext * 0x0215c440, JSObject * 0x0255b920, long
39730880, unsigned int 1, long * 0x0012f0e8, long * 0x0012f094) line 2794 + 31 bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x0215c5d0, void * 0x0255b920,
void * 0x025e3ec0, unsigned int 1, void * 0x0012f0e8, int * 0x0012f0e4) line 730
+ 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x02785a94) line 128 + 57 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x028f8b00,
nsIDOMEvent * 0x02785a94, unsigned int 8, unsigned int 7) line 703 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x0215cd80, nsEvent *
0x0012f64c, nsIDOMEvent * * 0x0012f5e4, unsigned int 7, nsEventStatus *
0x0012f66c) line 1197 + 35 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x028cd310, nsIPresContext *
0x0215cd80, nsEvent * 0x0012f64c, nsIDOMEvent * * 0x0012f5e4, unsigned int 1,
nsEventStatus * 0x0012f66c) line 3293
nsXULTreeElement::FireOnSelectHandler(nsXULTreeElement * const 0x02ee7fdc) line 556
nsXULTreeElement::SelectCell(nsXULTreeElement * const 0x02ee7fd8,
nsIDOMXULElement * 0x02f35320) line 209
nsTreeFrame::SetSelection(nsIPresContext * 0x0215cd80, nsTreeCellFrame *
0x0256e498) line 146
nsTreeCellFrame::HandleMouseDownEvent(nsIPresContext * 0x0215cd80, nsGUIEvent *
0x0012fac4, nsEventStatus * 0x0012f9d0) line 250
nsTreeCellFrame::HandleEvent(nsTreeCellFrame * const 0x0256e498, nsIPresContext
* 0x0215cd80, nsGUIEvent * 0x0012fac4, nsEventStatus * 0x0012f9d0) line 203
PresShell::HandleEvent(PresShell * const 0x023dbd84, nsIView * 0x02b7ce20,
nsGUIEvent * 0x0012fac4, nsEventStatus * 0x0012f9d0, int & 1) line 3457 + 38 bytes
nsView::HandleEvent(nsView * const 0x02b7ce20, nsGUIEvent * 0x0012fac4, unsigned
int 8, nsEventStatus * 0x0012f9d0, int & 1) line 811
nsView::HandleEvent(nsView * const 0x023da540, nsGUIEvent * 0x0012fac4, unsigned
int 28, nsEventStatus * 0x0012f9d0, int & 1) line 784
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x023da720, nsGUIEvent *
0x0012fac4, nsEventStatus * 0x0012f9d0) line 1354
HandleEvent(nsGUIEvent * 0x0012fac4) line 69
nsWindow::DispatchEvent(nsWindow * const 0x023da414, nsGUIEvent * 0x0012fac4,
nsEventStatus & nsEventStatus_eIgnore) line 498 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fac4) line 519
nsWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000) line 3137 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000) line 3344
nsWindow::ProcessMessage(unsigned int 513, unsigned int 1, long 10682417, long *
0x0012fd94) line 2317 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0030012e, unsigned int 513, unsigned int 1, long
10682417) line 676 + 27 bytes
USER32! 77e71820()

I think the assertions are caused by the default account still be set to account1.
ok, that may not be the cause.  but I'm getting a ton of assertions.  I'll leave
it to alecf to investigate.
(Assignee)

Comment 2

19 years ago
ugh. I can believe there are all sorts of problems and crashes around this
issue. fix ought to be easy
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: --- → M16
(Assignee)

Comment 3

19 years ago
Mass-update: setting P1 on M16 bugs for scheduling
(Assignee)

Comment 4

19 years ago
fixed, it was easy.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
Using build id: 2000-08-25-08 M18 on NT4.
Verified: Fixed
Status: RESOLVED → VERIFIED
QA Contact: lchiang → pratikd
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.