crash selecting OPTION in SELECT menu dynamically created and appendChild-ed during document load

VERIFIED DUPLICATE of bug 34893

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 34893
18 years ago
18 years ago

People

(Reporter: myk, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:

In a SELECT menu created and added to the document body via JavaScript and the
DOM methods while the document is still being loaded, selecting the second
option causes the browser to crash.  I am attaching a test case demonstrating
this problem.

Actual Results:

browser crashes

Expected Results:

browser selects option

Build Date & Platform Bug Found:

Linux 2000-04-06-08

Additional Builds and Platforms Tested On:

Linux M14, on which this problem does not occur.

Additional Information:

Bug 34893 is based on the same code snippet, and a remark has been made in that
bug that JavaScript code that runs while the page is being loaded should not be
allowed to modify the document body (except perhaps via document.write).
Perhaps the problem here is just allowing an illegal operation, and the solution
is to throw an error on any attempt to modify the DOM tree via appendChild while
the document is still loading.
(Reporter)

Comment 1

18 years ago
Created attachment 7324 [details]
test case
(Assignee)

Comment 2

18 years ago
Usually, I don't object to having each issue have its own bug, but this is 
really the same bug as 34893. 34893 is so messed up that this issue will go away 
when that is fixed.

*** This bug has been marked as a duplicate of 34893 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
Looks like the same bug all right.  It works for me when the other one does and

fails when the other one fails.  Verifying.



Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.