Firefox randomly crashes

RESOLVED DUPLICATE of bug 234598

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 234598
12 years ago
12 years ago

People

(Reporter: Chris Lambeth, Unassigned)

Tracking

({crash})

1.5.0.x Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060406 Firefox/1.5.0.4 (Debian-1.5.dfsg+1.5.0.4-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060406 Firefox/1.5.0.4 (Debian-1.5.dfsg+1.5.0.4-1)

while browsing normally, the browser will seem to die.  running the browser from a  shell, ive found it crashes with a Segmentation Fault error.  you will find the GDB degub info below in this bug report.

Reproducible: Sometimes

Steps to Reproduce:
1. re-open browser and continue work normally.
2. have looked for pattern in websites visited, etc., but nothing has emerged.  looked for uptime patterns, have seen none.  it may take a minute, an hour, or a day, but it will happen again.
3. searched forums, found others have had similar issue, ran gdb debugger, and was able to extract debug info.

Actual Results:  
it died.  i was able to extract the following information:


Thread 3 (Thread -1231303760 (LWP 679)):
#0  0xb7e39de2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
    from /lib/tls/libpthread.so.0
#1  0xb7e76a1f in pt_TimedWait (cv=0x8b4ee0c, ml=0x8b53428, 
    timeout=<value optimized out>) at ptsynch.c:280
#2  0xb7e76df4 in PR_WaitCondVar (cvar=0x8b4ee08, timeout=665) at ptsynch.c:407
#3  0xb7f0501c in TimerThread::Run (this=0x8b53628) at TimerThread.cpp:318
#4  0xb7f0278b in nsThread::Main (arg=0x8c451f0) at nsThread.cpp:118
#5  0xb7e7c94c in _pt_root (arg=0x8c3c2f8) at ptthread.c:220
#6  0xb7e37ced in start_thread () from /lib/tls/libpthread.so.0
#7  0xb745bdee in clone () from /lib/tls/libc.so.6

Thread 2 (Thread -1222173776 (LWP 678)):
#0  0xb7451819 in poll () from /lib/tls/libc.so.6
#1  0xb7e7af99 in PR_Poll (pds=0x8b9c7e8, npds=1, timeout=4294967295)
    at ptio.c:3877
#2  0x080fe0a9 in nsSocketTransportService::Poll (this=0x8b9c300, 
    interval=0xffffffff) at nsSocketTransportService2.cpp:359
#3  0x080fe7c1 in nsSocketTransportService::Run (this=0x8b9c300)
    at nsSocketTransportService2.cpp:568
#4  0xb7f0278b in nsThread::Main (arg=0x8b9ca98) at nsThread.cpp:118
#5  0xb7e7c94c in _pt_root (arg=0x8b9cb18) at ptthread.c:220
#0  0xb7451819 in poll () from /lib/tls/libc.so.6
#1  0xb7e7af99 in PR_Poll (pds=0x8b9c7e8, npds=1, timeout=4294967295)
    at ptio.c:3877
#2  0x080fe0a9 in nsSocketTransportService::Poll (this=0x8b9c300, 
    interval=0xffffffff) at nsSocketTransportService2.cpp:359
#3  0x080fe7c1 in nsSocketTransportService::Run (this=0x8b9c300)
    at nsSocketTransportService2.cpp:568
#4  0xb7f0278b in nsThread::Main (arg=0x8b9ca98) at nsThread.cpp:118
#5  0xb7e7c94c in _pt_root (arg=0x8b9cb18) at ptthread.c:220
#6  0xb7e37ced in start_thread () from /lib/tls/libpthread.so.0
#7  0xb745bdee in clone () from /lib/tls/libc.so.6

Thread 1 (Thread -1221858880 (LWP 673)):
#0  0x00000001 in ?? ()
#1  0x0a4f59b8 in ?? ()
#2  0xbfe1d4d4 in ?? ()
#3  0xbfe1d214 in ?? ()
#4  0x00000004 in ?? ()
#5  0x0a12c7c0 in ?? ()
#6  0x0a50a518 in ?? ()
#7  0x0912b678 in ?? ()
#8  0x00000000 in ?? ()


Expected Results:  
not died?

Updated

12 years ago
Keywords: crash
Version: unspecified → 1.5.0.x Branch

Comment 1

12 years ago
You didn't paste the thread that crashed.
Summary: will randomly die with Segmentation Fault. → Firefox randomly crashes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 234598
You need to log in before you can comment on or make changes to this bug.