Go to PREVIOUS (message, unread, flagged) MESSAGE does not work across folders

RESOLVED DUPLICATE of bug 310065

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 310065
12 years ago
12 years ago

People

(Reporter: Peter C. Frank, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Selecting (via keyboard shortcut, menu, or button) the PREVIOUS message button does not work across folders, unlike the NEXT message command.

For exampe, if I hit NEXT (message, unread, flagged) and there are no more (messages/unread message/flagged messaged) in the folder, I will be prompted if I wish to move to the next such message in the next folder that contains such message types. I should be able to hit PREVIOUS and have the same action, e.g., if there are more PREVIOUS messages (of whatever type) in the folder, I should be prompted to go to the next PREVIOUS message in the prior folder that contains whatever type of message I'm trying to go to.

Reproducible: Always

Steps to Reproduce:
Hit the "Previous" button on the toolbar, or use the menu command,

OR

Use the keyboard shortcut to go to the next PREVIOUS message (B or P), 

OR

Select "Go" from the main menu, then "Previous," then message type
Actual Results:  
Nothing happens.

Expected Results:  
I should be prompted to go to the previous message of whatever type (message, unread, flagged), in the previous folder containing such a message.

Comment 1

12 years ago
Go *Next* Message or Starred Message don't cross folders, either -- the cross-folder function was only intended for unread.  (See also bug 66466.)

The issue of Previous Unread not crossing folders has already been reported in bug 310065 for Thunderbird.  I thought there was a bug filed for this under the suite, too, but I can't locate it.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 310065
You need to log in before you can comment on or make changes to this bug.