flagtypes needs to have a clear/rerequest group

RESOLVED WONTFIX

Status

()

Bugzilla
Attachments & Requests
--
enhancement
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
we're running into flag abuse by people who are not members of canconfirm.

I need a new groupfield available to me that will enable flags to prevent transitions from:

+/?/- => unset aka "clear" aka "forget"
and
+/- => ? aka "rerequest" aka "reconsider"

the exact label for this is an implementation detail atm.

Basically if someone with grant permissions decides to mark something as + or -, then they should not be overruled by someone who doesn't have whatever minimum reconsider group is specified.

I am aware that people can spam bugs instead of playing flag games, but that's not a problem I can deal with.

Comment 1

12 years ago
Set the request group to "canconfirm". Users not having this privs won't be able to change flags (including requesting "?"). What you want is to back out myk's patch from bug 291391.

I would tend to WONTFIX this bug.
Lately I noticed that probably users without canconfirm privs have removed several blocking1.9.0.1- flags. I have to agree that we can run into information loss when it will happen on important bugs and the cleared flags cannot be set anymore because they aren't available anymore.
OS: Windows XP → All
Hardware: PC → All

Comment 3

10 years ago
As I said in comment 1, define the request group and the problem is fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.