If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problems with nsLocalFileUnix::Normalize

RESOLVED DUPLICATE of bug 110769

Status

()

Core
XPCOM
P2
normal
RESOLVED DUPLICATE of bug 110769
11 years ago
11 years ago

People

(Reporter: Waldo, Unassigned)

Tracking

({platform})

Trunk
x86
All
platform
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This function is implemented using the POSIX realpath, which returns errors when the file path mentioned does not exist.  Consequently, .normalize() is broken on non-existent files.

Additionally, use of realpath means that .normalize() goes beyond the behavior specified in IDL docs and resolves symlinks.
This bug affects MacOS builds as well; according to sayrer, it uses the same approach.  OS -> All.

Note this bug does NOT affect Windows; requesting blocking1.9 and adding platform keyword for this reason.
Blocks: 367608
Flags: blocking1.9?
Keywords: platform
OS: Linux → All
(note: I'm most concerned about the inconsistency across platforms; if this is desired behavior, that's fine.  I just want all major platforms to do the same thing.)
Created attachment 262071 [details] [diff] [review]
wild guess patch for Mac (works)

I'm not taking this bug because I can't work on it on Linux, and I'm only about 30% confident that this patch does the right thing.  I'm simply posting it for comments.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9? → blocking1.9-
Priority: -- → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 110769
You need to log in before you can comment on or make changes to this bug.