"Text-align" takes no effect (on td which has the "text-align" css property) when a suit of table(display:inline),tr,td(text-align:center) elements nested in another suit of table,tr,td elements.

RESOLVED WONTFIX

Status

()

Core
Layout
--
minor
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: tony, Unassigned)

Tracking

({testcase})

1.8 Branch
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

"Text-align" takes no effect (on td which has the "text-align" css property) when a suit of table(display:inline),tr,td(text-align:center) elements nested in another suit of table,tr,td elements until any elements' appearence changed or "href='#'" be clicked or firebug(extension) enter the "inspect" mode.

Now i found a hack to fix the problem via css. is to add "display:block" on the td element which has the "text-align" css property.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 234368 [details]
a page to show the bug in all situations and a fix method
(Reporter)

Comment 2

11 years ago
Created attachment 234369 [details]
the png picture for the bug demo page
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch
(Reporter)

Comment 3

11 years ago
Created attachment 234371 [details]
a page to demonstrate the bug in all situations and a fix method
Attachment #234368 - Attachment is obsolete: true
(Reporter)

Comment 4

11 years ago
Created attachment 234373 [details]
review picture
Attachment #234373 - Flags: superreview?
Attachment #234373 - Flags: review?
Created attachment 234430 [details]
testcase, which can be viewed online

This is basically "a page to demonstrate the bug in all situations and a fix method", but this one you can view online, because the img's work now.

The testcase is wfm, with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060802 SeaMonkey/1.5a

I think this is already fixed somehow on trunk.
Attachment #234371 - Attachment is obsolete: true

Updated

11 years ago
Attachment #234373 - Flags: superreview?
Attachment #234373 - Flags: review?
I can see the bug on the 1.8 branch, though.
Keywords: testcase
As a branch bug, this is wontfix, imo.  No way do we want to be messing with obscure parts of table layout on the branch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.