Closed Bug 349114 Opened 14 years ago Closed 11 years ago

"Save page as, complete" in smoketest downloads html by default.

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 115107

People

(Reporter: gjmatt, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060817 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060817 SeaMonkey/1.5a

"Save page as, complete" in smoke test downloads html by default. It displays that the complete is your choice. Clicking on another choice and then complete worked once showing 12KB size and the rest show 1KB and only the html, css but no images and loading the page from file is missing the background .gif (Mozilla.org logo and shading).

Reproducible: Always

Steps to Reproduce:
"copied from the smoke test with my notes in ()" 
1. Open browser to http://www.mozilla.org/mozorg.html
2. From the toplevel menu, select File | Save Page As
3. In the resulting file picker, make sure "Web Page, complete" is selected. (it should be the default)
4. Choose a target directory (e.g., your desktop or home directory).
5. Click the Save button.

Actual Results:  
download manager displays the progress as finished and a size of 1KB. The html and folder with css cases have downloaded but no images.

Expected Results:  
If it worked should have a 12KB size.

should have not needed to make three extra clicks that displays the choice wanted in field.
Attachment #234372 - Attachment description: the results of the downlaod attempt → the results of the downlaod attempt (html only)
Can confirm that the logo and shading are not downloaded. Duplicate of bug 126309?

> 
> should have not needed to make three extra clicks that displays the choice
> wanted in field.
> 

Can also confirm that only 1K is reported in the download manager (intentional perhaps?). I'm not able to make it display the correct size. Could you clarify how you did so please?
Version: unspecified → Trunk
(In reply to comment #2)
> Can also confirm that only 1K is reported in the download manager (intentional
> perhaps?). I'm not able to make it display the correct size.

And this part is probably a duplicate of bug 149237.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 115107
You need to log in before you can comment on or make changes to this bug.