Padlock symbol in statusbar not displayed correctly

VERIFIED FIXED in Firefox 2

Status

()

Firefox
General
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: dex_sf, Assigned: Pam Greene)

Tracking

({regression, verified1.8.1})

unspecified
Firefox 2
PowerPC
Mac OS X
regression, verified1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060818 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060818 BonEcho/2.0b2

On the Mac the padlock symbol in the status bar is placed too high, so that the top is cut and apparently the top of a lighter version of the padlock icon is showed below. 

Reproducible: Always

Steps to Reproduce:
1. load https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=nowords&keywords=fixed1.8.1+verified1.8.1&emailtype1=substring&email1=&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=flagtypes.name&type0-0-0=equals&value0-0-0=blocking-firefox2%2B&field0-0-1=flagtypes.name&type0-0-1=equals&value0-0-1=blocking1.8.1%2B&field0-1-0=target_milestone&type0-1-0=equals&value0-1-0=Firefox+2+beta2&field0-1-1=target_milestone&type0-1-1=equals&value0-1-1=mozilla1.8.1beta2


Actual Results:  
On the Mac the padlock symbol in the status bar is placed too high, so that the top is cut off and apparently the top of a lighter version of the padlock symbol is showed below.

Expected Results:  
The padlock symbol in the status bar should be shown correctly.

Comment 1

12 years ago
Summary: padlock image in status bar misaligned

Reproduced in Bon Echo Beta 2 (2006081806) on Mac OS 10.4:

The padlock image in the status bar isn't correctly vertically aligned.

Additionally it has a weird repeating behavior: I can make out the top of the padlock faintly appearing below the main image.  (This is not affected by resizing the browser window.)

This should be in Component: Toolbars, Version: 2.0 Branch (1.5.0.6 and Minefield use a different padlock image and don't have this problem), Severity: trivial, but I don't have the privileges...
I see this using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060818 BonEcho/2.0b2. Screenshot coming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox2?
Keywords: regression
Target Milestone: --- → Firefox 2 beta2
Created attachment 234511 [details]
Padlock off kilter.
plussing for blocking release, but not blocking beta2 ...
Flags: blocking-firefox2? → blocking-firefox2+
Whiteboard: [Fx2 theme change]
Target Milestone: Firefox 2 beta2 → Firefox 2
*lob*
Assignee: nobody → dietrich
*** Bug 350189 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

12 years ago
Created attachment 235419 [details] [diff] [review]
Fixed image regions for new 16x16-pixel lock
Assignee: dietrich → pamg.bugs
Status: NEW → ASSIGNED
Attachment #235419 - Flags: review?(mconnor)
Attachment #235419 - Flags: approval1.8.1?
Comment on attachment 235419 [details] [diff] [review]
Fixed image regions for new 16x16-pixel lock

r+a=me on this theme fix.  Thanks Pam!
Attachment #235419 - Flags: review?(mconnor)
Attachment #235419 - Flags: review+
Attachment #235419 - Flags: approval1.8.1?
Attachment #235419 - Flags: approval1.8.1+
Whiteboard: [Fx2 theme change] → [Fx2 theme change][checkin needed (1.8.1 branch)]
(Assignee)

Comment 9

12 years ago
Landed on branch only.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [Fx2 theme change][checkin needed (1.8.1 branch)] → [Fx2 theme change]
(Assignee)

Comment 10

12 years ago
Regressed by bug 352200, which returned the image to 18x18px.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
(Assignee)

Comment 11

12 years ago
Created attachment 237999 [details] [diff] [review]
Fixed image regions for reverted 18x18-pixel lock
Attachment #235419 - Attachment is obsolete: true
Attachment #237999 - Flags: review?(mconnor)
Attachment #237999 - Flags: approval1.8.1?

Comment 12

12 years ago
MConnor - when you review please go ahead and 1.8.1+ from drivers as well.
Comment on attachment 237999 [details] [diff] [review]
Fixed image regions for reverted 18x18-pixel lock

ack!

thanks Pam!
Attachment #237999 - Flags: review?(mconnor)
Attachment #237999 - Flags: review+
Attachment #237999 - Flags: approval1.8.1?
Attachment #237999 - Flags: approval1.8.1+
(Assignee)

Comment 14

12 years ago
Landing on 1.8.1 branch.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Reporter)

Comment 15

12 years ago
Is it intended that the height of the status bar changes (it gets 2px higher) now each time the padlock is displayed?
(Assignee)

Updated

12 years ago
Blocks: 353194
(Assignee)

Comment 16

12 years ago
(In reply to comment #15)
> Is it intended that the height of the status bar changes (it gets 2px higher)
> now each time the padlock is displayed?

Filed as bug 353194.
No longer blocks: 353194

Updated

11 years ago
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1 → verified1.8.1
You need to log in before you can comment on or make changes to this bug.