No rule to make target `../protocol/jar/src/libnkjar_s.a', needed by `libnecko.so'

RESOLVED INVALID

Status

Minimo
Build Config
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Lucas C. Villa Real, Assigned: dougt)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051107 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051107 Firefox/1.0.7

When compiling Minimo for the x86, 'make' tries to build the object netwerk/protocol/jar/src/libnkjar_s.a, which doesn't exist. As a workaround I've added 'jar' to the filter-out 'foreach' look.

Since I'm not familiar to Mozilla internals, I'm not sure whether that directory could be created if another configure options were used or not. Anyway, the patch I used to fix that follows.

Reproducible: Always

Steps to Reproduce:

1. Environment variables at compile time are the following ones:
   MOZCONFIG=$dir/minimo-cc-opt.mozconfig
   GTK_CONFIG="`which pkg-config` $goboLibraries/pkgconfig/gtk+-2.0.pc"
   GLIB_CONFIG="`which pkg-config` $goboLibraries/pkgconfig/glib-2.0.pc"
   LIBIDL_CONFIG="$goboExecutables/libIDL-config-2"
   HOST_LIBIDL_CONFIG=`which libIDL-config-2`

   $goboLibraries and $goboExecutables are just the same as /bin and /lib on
standard distributions.

2. Configure flags used:
    --enable-application=minimo
    --with-embedding-profile=basic
    --disable-official-branding
    --enable-default-toolkit=gtk2
    --disable-gtktest
    --disable-freetype2
    --enable-xft
    --disable-xul
    --disable-profilesharing
    --disable-profilelocking
    --enable-single-profile
    --disable-accessibility
    --disable-composer
    --enable-plaintext-editor-only
    --disable-mailnews
    --disable-ldap
    --disable-postscript
    --disable-mathml
    --disable-jsd
    --disable-jsloader
    --disable-installer
    --disable-xpinstall
    --disable-xpfe-components
    --disable-xprint
    --disable-printing
    --disable-necko-disk-cache
    --disable-gnomevfs
    --disable-gnomeui
    --disable-xpcom-obsolete
    --disable-xpcom-fastload
    --disable-updater
    --disable-static
    --disable-js-static-build
    --disable-javaxpcom
    --disable-xpconnect-idispatch
    --disable-rdf
    --enable-necko-small-buffers
    --disable-dtd-debug
    --disable-logging
    --disable-tests
    --disable-crypto
    --enable-necko-protocols=http,file,res,jar
    --enable-image-decoders=png,gif,jpeg
    --enable-optimize=-Os
    --enable-strip
    --disable-debug
    --enable-reorder
    --enable-elf-dynstr-gc

3. Ran 'make -f client.mk build'. Since I'm calling configure by hand, I've
disabled the 2nd call to configure at client.mk again, at line 1003 on today's
cvs snapshot.
Actual Results:  
No rule to make target `../protocol/jar/src/libnkjar_s.a', needed by `libnecko.so'
(Reporter)

Comment 1

12 years ago
Created attachment 234479 [details] [diff] [review]
Fix used to workaround the problem.

Patch against today's cvs snapshot.
you shouldn't put "jar" in the protocol list here:
    --enable-necko-protocols=http,file,res,jar
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.