[reflow branch] Horizontal scrollbar on annevankesteren blog

RESOLVED DUPLICATE of bug 478834

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 478834
13 years ago
4 years ago

People

(Reporter: martijn.martijn, Assigned: dbaron)

Tracking

({regression, testcase})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 -
wanted1.9.1 +
blocking1.9 -
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [float pref width][dbaron-1.9:RwCr], )

Attachments

(2 attachments, 1 obsolete attachment)

652 bytes, text/html
Details
344 bytes, text/html
Details
Reporter

Description

13 years ago
I get a horizontal scrollbar on the annevankesteren blog with the reflow branch, which should not happen.
Reporter

Comment 1

13 years ago
Posted file testcase (obsolete) —
So the problem is that block-level replaced elements can end up next to floats, but nsBlockFrame::GetPrefWidth does a Break() on any block line without considering floats.  We probably need to modify one or the other...
For what it's worth -- what the intrinsic width here should be is questionable.  But there's definitely a bug here in the reflow code for replaced blocks (in general) -- we should clear them past floats when they don't fit next to the floats.
Whiteboard: [float pref width]

Updated

12 years ago
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Whiteboard: [float pref width] → [float pref width][dbaron-1.9:RwCr]

Updated

12 years ago
Keywords: regression
The clearing past floats in comment 3 would also fix the image at the top right of http://www.nytimes.com/2007/11/26/opinion/26krugman.html?pagewanted=print from overflowing at narrow window widths.

Comment 5

12 years ago
Repro'd on Mac.
->All/All
OS: Windows XP → All
Hardware: PC → All
Fixed by checkin of bug 134706.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Reporter

Updated

12 years ago
Flags: in-testsuite?
Bug 437766 seems to be a duplicate. For some reason the scrollbar is still visible here; I tried builds before and after the fix.

Comment 8

11 years ago
The testcase no longer reproduces the bug, but it's still visible on Anne's site. (I'm on Linux with RC2.)

Updated

11 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

11 years ago
Posted file New testcase
This testcase still reproduces the bug for me. However, I am not sure if it's really a bug, as Konqueror also displays a horizontal scrollbar.
Attachment #234517 - Attachment is obsolete: true
I'd guess that the problem there would be that nsBlockFrame::BlockCanIntersectFloats is somehow returning true for the submit input when it should really be returning false.
Actually, it seems like the problem is that ApplyTopMargin is false in nsBlockFrame::ReflowBlockFrame, so we don't do the clearing.
Reporter

Updated

11 years ago
Duplicate of this bug: 437766

Comment 13

11 years ago
Posted file New testcase 2
a bit reduced and generalized
Flags: blocking1.9.1?
Flags: blocking1.9-
Flags: blocking1.9+
Not going to block 1.9.1, but a P2 wanted.   
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Priority: P3 → P2

Comment 15

10 years ago
Another example in the wild is http://www.allpcdrivers.com/

Comment 16

6 years ago
Still a problem on Nightly 27. Works correctly on Chrome 29 and IE10.
Both attachment 324199 [details] and attachment 324312 [details] were fixed by bug 478834.
Status: REOPENED → RESOLVED
Closed: 12 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478834
You need to log in before you can comment on or make changes to this bug.