Closed Bug 349319 Opened 14 years ago Closed 14 years ago

If you have both the en-GB and the en-GB-oed dictionaries installed you can't distinguish them when trying to select the correct dictionary

Categories

(Core :: Spelling checker, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED FIXED

People

(Reporter: philip.chee, Assigned: iann_bugzilla)

Details

(4 keywords)

Attachments

(2 files, 1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060817
But IanN says this affects TB and Editor too.

1. Install both the en-GB and the en-GB-oed dictionaries from <http://en-gb.pyxidium.co.uk/dictionary/mozilla.php>

2. In SeaMonkey go Edit->Preferences->Mail&Newsgroups->Composition.
In the language list box both appear as "English/United Kingdom"

Expected result: Something to disambiguate these two dictionaries.
Assignee: mscott → iann_bugzilla
Status: NEW → ASSIGNED
Attached patch Check for 3rd of array v0.1 (obsolete) — Splinter Review
This patch:
* Checks for a 3rd part of isoStrArray and, if it exists, uses it.
Attachment #234587 - Flags: review?(neil)
Attachment #234587 - Flags: review?(neil)
Changes since v0.1:
* Added check into MsgComposeCommands.js (thanks to Ratty on IRC)
Attachment #234587 - Attachment is obsolete: true
Attachment #234592 - Flags: review?(neil)
Attachment #234592 - Flags: review?(neil) → review+
Attachment #234592 - Flags: superreview?(mscott)
I can confirm that with the latest patch this is now working on SeaMonkey Trunk. I don't have Thunderbird trunk available to test yet.
Attachment #234592 - Flags: superreview?(mscott) → superreview+
Since the files are forked, is it possible to have separate blocking-seamonkey flags?
Flags: blocking1.8.1?
Whiteboard: [blocking&#8209;seamonkey1.1b?] [blocking&#8209;seamonkey1.0.5b?]
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

Checking in (trunk)
editor/ui/dialogs/content/EdSpellCheck.js;
new revision: 1.60; previous revision: 1.59
mailnews/compose/prefs/resources/content/pref-composing_messages.js;
new revision: 1.3; previous revision: 1.2
mailnews/compose/resources/content/MsgComposeCommands.js;
new revision: 1.385; previous revision: 1.384
mail/components/compose/content/EdSpellCheck.js;
new revision: 1.6; previous revision: 1.5
mail/components/compose/content/MsgComposeCommands.js;
new revision: 1.100; previous revision: 1.99
mail/components/preferences/compose.js;
new revision: 1.10; previous revision: 1.9
done
Attachment #234592 - Attachment description: Check for 3rd everywhere v0.1a → Check for 3rd everywhere v0.1a (Checked in trunk)
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

Requesting a= for 1.8.1 safe and simple fix for that branch.
Also requesting for 1.8.0.7/8 in case it is wanted for that branch but might be considered more of an enhancement than a fix.
Attachment #234592 - Flags: approval1.8.1?
Attachment #234592 - Flags: approval1.8.0.8?
Attachment #234592 - Flags: approval1.8.0.7?
We'll consider the patch, but this won't block release.
Flags: blocking1.8.1? → blocking1.8.1-
Whiteboard: [blocking&#8209;seamonkey1.1b?] [blocking&#8209;seamonkey1.0.5b?] → [would take patch][blocking&#8209;seamonkey1.1b?][blocking&#8209;seamonkey1.0.5b?]
Whiteboard: [would take patch][blocking&#8209;seamonkey1.1b?][blocking&#8209;seamonkey1.0.5b?] → [baking until 8/26][would take patch][blocking&#8209;seamonkey1.1b?][blocking&#8209;seamonkey1.0.5b?]
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

too late in 1.8.0.7 for this kind of fix, leaving the 1.8.0.8 request.
Attachment #234592 - Flags: approval1.8.0.7? → approval1.8.0.7-
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

a=schrep approving all patches that have baked without noted regressions/
Attachment #234592 - Flags: approval1.8.1? → approval1.8.1+
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

Checking in (1.8.1 branch)
editor/ui/dialogs/content/EdSpellCheck.js;
new revision: 1.57.28.3; previous revision: 1.57.28.2
mailnews/compose/prefs/resources/content/pref-composing_messages.js;
new revision: 1.1.2.3; previous revision: 1.1.2.2
mailnews/compose/resources/content/MsgComposeCommands.js;
new revision: 1.369.2.8; previous revision: 1.369.2.7
mail/components/compose/content/EdSpellCheck.js;
new revision: 1.4.4.2; previous revision: 1.4.4.1
mail/components/compose/content/MsgComposeCommands.js;
new revision: 1.72.2.21; previous revision: 1.72.2.20
mail/components/preferences/compose.js;
new revision: 1.2.4.7; previous revision: 1.2.4.6
done
Attachment #234592 - Attachment description: Check for 3rd everywhere v0.1a (Checked in trunk) → Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.1 branch)
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [baking until 8/26][would take patch][blocking&#8209;seamonkey1.1b?][blocking&#8209;seamonkey1.0.5b?] → [baking until 8/26][would take patch][blocking-seamonkey1.0.5b?]
This patch:
* Adds check for and uses 3rd item in array (as used everywhere else now).
* Removes unneeded var declaration.
Attachment #241764 - Flags: review?
Attachment #241764 - Flags: review? → review?(brettw)
Comment on attachment 241764 [details] [diff] [review]
toolkit patch v0.1b (Checked into trunk & 1.8.1 branch)

Looks good. I'm assuming this will produce something like "English (en-GB)" in the menu?
Attachment #241764 - Flags: review?(brettw) → review+
(In reply to comment #12)
> (From update of attachment 241764 [details] [diff] [review] [edit])
> Looks good. I'm assuming this will produce something like "English (en-GB)" in
> the menu?
> 
No, this is for when you have a variation, so would produce:
English / United Kingdom (oed)
Attachment #241764 - Flags: superreview?(mscott)
Attachment #241764 - Flags: superreview?(mscott) → superreview+
Comment on attachment 241764 [details] [diff] [review]
toolkit patch v0.1b (Checked into trunk & 1.8.1 branch)

Checking in (trunk)
inlineSpellCheckUI.js;
new revision: 1.10; previous revision: 1.9
done
Attachment #241764 - Attachment description: toolkit patch v0.1b → toolkit patch v0.1b (Checked into trunk)
Comment on attachment 241764 [details] [diff] [review]
toolkit patch v0.1b (Checked into trunk & 1.8.1 branch)

Requesting a= for 1.8.1.1 for simple UI fix, very low risk.
Attachment #241764 - Flags: approval1.8.1.1?
Comment on attachment 241764 [details] [diff] [review]
toolkit patch v0.1b (Checked into trunk & 1.8.1 branch)

approved for 1.8 branch, a=dveditz for drivers
Attachment #241764 - Flags: approval1.8.1.1? → approval1.8.1.1+
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #234592 - Flags: approval1.8.0.9? → approval1.8.0.9+
Comment on attachment 241764 [details] [diff] [review]
toolkit patch v0.1b (Checked into trunk & 1.8.1 branch)

Checking in (1.8.1 branch)
inlineSpellCheckUI.js;
new revision: 1.2.10.8; previous revision: 1.2.10.7
done
Attachment #241764 - Attachment description: toolkit patch v0.1b (Checked into trunk) → toolkit patch v0.1b (Checked into trunk & 1.8.1 branch)
Comment on attachment 234592 [details] [diff] [review]
Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)

Checking in (1.8.0 branch)
editor/ui/dialogs/content/EdSpellCheck.js;
new revision: 1.57.36.1; previous revision: 1.57
mail/components/compose/content/EdSpellCheck.js;
new revision: 1.4.12.1; previous revision: 1.4
mail/components/compose/content/MsgComposeCommands.js;
new revision: 1.72.2.6.2.3; previous revision: 1.72.2.6.2.2
mail/components/preferences/compose.js;
new revision: 1.2.4.3.2.1; previous revision: 1.2.4.3
done
Attachment #234592 - Attachment description: Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.1 branch) → Check for 3rd everywhere v0.1a (Checked in trunk & 1.8.0 / 1.8.1 branch)
Whiteboard: [baking until 8/26][would take patch][blocking-seamonkey1.0.5b?]
There are no SeaMonkey specific flags available in this component so I'm putting this in the whiteboard for SeaMonkey 1.0.7 which is equivalent to 1.8.0.9
Whiteboard: [wanted-sm1.0.7?]
(In reply to comment #20)
> There are no SeaMonkey specific flags available in this component so I'm
> putting this in the whiteboard for SeaMonkey 1.0.7 which is equivalent to
> 1.8.0.9
> 
As far as I am aware it got checked into the 1.8.0.x branch yesterday, so could you check the issue is fixed in a build generated after then?

OK The latest SeaMonkey 1.0.x branch builds have this fix. Sorry for the false alarm.
Whiteboard: [wanted-sm1.0.7?]
Verified that these en-GB dictionaries are distinguishable in the appropriate lists (Editor, Composer, form field spelling) on latest 1.8 and 1.8.1 Seamonkey, Thunderbird and Firefox, linux and windows (with BuildIDs: 20061129xx).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.