Closed Bug 349357 Opened 14 years ago Closed 4 years ago

[Mac] Tab should go to <select> even without full keyboard access

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 437296

People

(Reporter: donaldsbell, Unassigned)

References

()

Details

(Whiteboard: p-safari)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The <SELECT> form elements are skipped when navigating through a form using the tab key.

I've tried sevehttps://bugzilla.mozilla.org/enter_bug.cgi?product=Firefoxral sites, and the behavior seems to be consistent regardless of site.

I've tried the aa.com site using Safari and when I tab through the form, Safari navigates to <SELECT> form elements (as I would expect it to).

Reproducible: Always

Steps to Reproduce:
1. Go to www.aa.com
2. Put your cursor in the "From City or Airport" text box.
3. Enter an airport code (i.e. LGA or XNA).
4. Press the tab key

Actual Results:  
The "To City or Airport" text box receives focus.

Expected Results:  
The "Departure Month" drop down should have received focus.

I don't think this is relevant, but I'll include it anyway; I am using a Mac Mini with a PC keyboard.
Firefox respects what you have set in System Preferences. You'll need to change the setting if you want this functionality.

*** This bug has been marked as a duplicate of 187508 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I wouldn't be surprised if this is a duplicate, but not of that. Apple HIG says that without full keyboard access you should tab through "text entry fields, list boxes that support type-ahead," and I'd agree with Safari that a <select> is more a list box than a popup menu.
Component: Form Manager → Keyboard: Navigation
Product: Firefox → Core
QA Contact: form.manager → keyboard.navigation
Summary: The <SELECT> form elements are skipped when navigating through a form using the tab key. → [Mac] Tab should go to <select> even without full keyboard access
Version: unspecified → Trunk
It's interesting (and perhaps a Safari bug) that Safari does this, because popup menus elsewhere in the OS definitely don't get focused when FKA is off.  Now, if the select were listbox-style on that page, I could see that argument, but it's not.
(In reply to comment #5)
> It's interesting (and perhaps a Safari bug) that Safari does this, because
> popup menus elsewhere in the OS definitely don't get focused when FKA is off. 

Apple seems not to think it's a bug, since Safari 3 (along with all WebKit browsers) continues this practice.  I still think it's odd, though, since it doesn't match the rest of the OS.  That, or hyatt hasn't figured out how to differentiate between select-as-popup-menu and select-as-listbox yet, which I find improbable ;)
Whiteboard: p-safari
Duplicate of this bug: 411533
Duplicate of this bug: 432426
Duplicate of this bug: 439824
(In reply to comment #6)
> (In reply to comment #5)
> > It's interesting (and perhaps a Safari bug) that Safari does this, because
> > popup menus elsewhere in the OS definitely don't get focused when FKA is off. 
> 
> Apple seems not to think it's a bug, since Safari 3 (along with all WebKit
> browsers) continues this practice.  I still think it's odd, though, since it
> doesn't match the rest of the OS.  That, or hyatt hasn't figured out how to
> differentiate between select-as-popup-menu and select-as-listbox yet, which I
> find improbable ;)

I filed a safari bug to see if it is a bug or not:
https://bugs.webkit.org/show_bug.cgi?id=19648
Hyatt has answered:

(In reply to comment #1)
> It's not a bug.  We do this on purpose for compatibility.

(In reply to comment #2)
> We make an exception for the dropdown list even though it does not match the
> OS, since it just makes it easier to fill out forms from the keyboard without
> having to turn on full keyboard access.

So, can this bug be confirmed?
Alright, confirming for parity with Safari due to Hyatt's response that it's not a bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 442386
Bug 437296 is really a dupe of this, but yay MoCo for filing new bugs without searching :P
Status: NEW → RESOLVED
Closed: 14 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437296
Duplicate of this bug: 545883
(In reply to comment #14)
> Bug 437296 is really a dupe of this, but yay MoCo for filing new bugs without
> searching :P
> 
> *** This bug has been marked as a duplicate of bug 437296 ***

Per the discussion in bug 437296 comment 16, bug 437296 comment 33, and bug 437296 comment 34, bug 437296 is different (it's currently about setting accessibility.tabfocus to 3 for content on Mac OS X), so un-duping.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Excuse me for asking a stupid question, but now that bug 437296 is fixed "ignore mac keyboard setting for tabbing for <input>, <select> and <button>", what's left unfixed for this bug?
(In reply to comment #17)
> Excuse me for asking a stupid question, but now that bug 437296 is fixed
> "ignore mac keyboard setting for tabbing for <input>, <select> and <button>",
> what's left unfixed for this bug?

Bug 437296 is not fixed in Firefox 3.6.13. I still can't tab to selects and other buttons. When a bug is marked "FIXED" how do you know which version of the product it's fixed in? 

In agreement with numerous comments in that bug, I don't see a reason to not allow tabbing to all form controls. Either a person uses keyboard shortcuts or they don't. Why would I want to use the keyboard for some form controls and not others?
At least for me, this is fixed now.
This works for me too.
Status: REOPENED → RESOLVED
Closed: 12 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437296
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.