All users were logged out of Bugzilla on October 13th, 2018

There are problems with the adaptive junk filtering user interface and "Junk" "Not Junk" options.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: dontosaw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-09-09)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/thunderbird-3.0a1.en-US.win32.installer.exe

I have experienced this issue with both the latest stable release 1.5.0.5 and the latest alpha development release version 3 alpha 1 (20060819). When the Junk folder is opened, the Junk/Not Junk button in the toolbar does not change from a "Junk" to a "Not Junk" button. So there is no easy way for users to mark the misidentified message as "Not Junk". This issue started as an intermittent issue, but has become persistent. The only way I can mark messages misidentified as junk, is by right-clicking the message and selecting "Mark as Not Junk". When I do this nothing happens to let me know that the command was executed. Isn't the message supposed to be moved to the Inbox? If not, take this as a suggestion to add this behavior.

Reproducible: Sometimes

Steps to Reproduce:
1.After downloading messages, open the Junk folder.
2.Select a message.
3.Look at Junk/Not Junk button.

Actual Results:  
The button is labeled as "Junk", when it should be labeled "Not Junk". Also, the pointer label indicated that the button is for marking messages as junk.

Expected Results:  
The Junk/Not Junk button should be labeled as "Not Junk" and the pointer label should state, "Mark the selected message as not junk".
(Reporter)

Comment 1

12 years ago
I have noticed that the Junk/Not Junk button changes between its Junk and Not Junk functionality when different messages in the Junk fold are selected. It seems that  the button is labeled as a Junk button when I select messages from senders that have previously sent messages that were misidentified as junk and that I had marked as not junk. This brings up another question, if I mark a message in the junk folder as not junk, shouldn't the adaptive filter refrain from filtering future messages from the same sender? If so, this is obviously not happening.

Comment 2

11 years ago
Bruce, do you also see the problem described here?

Comment 3

11 years ago
No, nothing similar.

Comment 4

11 years ago
Don, best if you address each issue in a separate bug

1. Do you see in thunderbird v2 and trunk that mouseover (what you call "pointer label") junk icon in toolbar gives "mark the selected message as not junk"?  It works for me.

2. I think there is an open bug for marking a message "not junk" in junk folder to move message back to inbox/original folder.  If you don't find it please file a new bug.

3. (from comment 1) "shouldn't the adaptive filter refrain from filtering future messages from the same sender?" isn't the way bayesian junk processing works.  marking a message as "not junk" does not whitelist the sender - because whether a message gets marked as junk depends on several headers and other content in training.dat.  To explicitly whitelist a sender add an addressbook entry and in account junk settings select the address book(s) to whitelist.


David, is there a flag in a message that shows it has been marked as junk?

Comment 5

11 years ago
Wayne, yes, there is an attribute on a message that says whether it's been marked as junk, non junk, or not marked at all, and whether the user marked it as junk, or the spam filter.

Comment 6

11 years ago
Don appears to be gone - dead address ?
Assignee: mscott → nobody
Reporter could answer to comment #4, please?
Whiteboard: closeme 2009-09-09
RESO INCO due to lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.