Appears a stray tfoot tag crashes FF in file/print or file/print preview

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: andy, Unassigned)

Tracking

({crash, stackwanted, testcase})

1.8 Branch
x86
All
crash, stackwanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Attempting to print a report, crash (sent in crash report to Mozilla and Microsoft)   Began whittling down the html. I've got the tidy plug-in, so cleaned up all the warning (no errors).  At some point, the file could be previewed so began to reverse the process.  In the end, it appeared to be the existance of a single <TFOOT> tag between <TR> and a </TR> in the middle of admittedly messy <TABLE>

Reproducible: Always

Steps to Reproduce:
1. open the html file (attached)
2. select File/print preView
3.

Actual Results:  
Crash. FF goes away. A Notify MS box pops up.

Expected Results:  
Doesn't crash
(Reporter)

Comment 1

12 years ago
Created attachment 234847 [details]
html file that causes crash here

Doesn't crash IE ;->

Updated

12 years ago
Attachment #234847 - Attachment mime type: text/plain → text/html
That testcase works for me - can you give us the Talkback ID from your crash? (See http://kb.mozillazine.org/Talkback for how to find it.)
Severity: normal → critical
Component: File Handling → General
Keywords: crash, stackwanted
Product: Firefox → Core
QA Contact: file.handling → general
Version: unspecified → 1.8 Branch

Comment 3

12 years ago
I did see a crash with Gecko/20060111 Firefox/1.6a1 TB22375812Z but I do not crash with a current trunk debug. Probably not backported

Comment 4

12 years ago
The bug occurs with Firefox/1.5.0.6 on Linux: TB23187827K
The bug does NOT occur for me using Firefox/1.5.0.7pre or 2.0b2
So there is some chance this will be fixed in Firefox 1.5.0.7 and 2.0.
Status: UNCONFIRMED → NEW
Component: General → Layout: Tables
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
QA Contact: general → layout.tables

Comment 5

12 years ago
probably fixed by 302911 which went in to branches as part of the cumulative branch cellmap patch.

Comment 6

12 years ago
please reopen if you still see this and post a talkback or a stack.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.