Using document.location="newpage.html" on onclick does not work

VERIFIED DUPLICATE of bug 33650

Status

()

P3
normal
VERIFIED DUPLICATE of bug 33650
19 years ago
19 years ago

People

(Reporter: smuench, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I have many web applications that use a two-frame design. A navigator
page on the left and a details page on the right. My applications
use an anchor like:

<a href="newpageforright.html" target="rightframe"
   onclick="document.location='newpageforleft.html'">Click Me</a>

which has the effect in Netscape 4.X and MSIE of refreshing *both*
the left and right panes with a single click on the link.

In Netscape 6 Preview Release 1, the onclick="document.location='newpage.html'"
does nothing.

Comment 1

19 years ago
bugzilla is not the place to report bugs for Netscape products; see 
http://www.mozilla.com/bugs for a link to a Netscape bug report where you may 
do that.

on the other hand, if you've downloaded the latest nightly build and the bug 
still exists, be sure to include the build you're using and report the bug as a 
Mozilla one.

Comment 2

19 years ago
changing component to Parser, adding self to cc list, changing severity to 
normal
smuench@oracle.com, can you provide a testcase or an URL please?  i'm marking 
INVALID for now unless you're able to reproduce on the latest Moz nightly 
build, as your post refers only to NS6PR1
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Component: Browser-General → Parser
Resolution: --- → INVALID
(Reporter)

Comment 3

19 years ago
I did the following tonight with build 2000040815 to demonstrate the problem 
still exists:

Browse the url:

http://ws5.olab.com

Try clicking on the tabs. The tab page content does not refresh correctly.

The frame with the tabs is either calling g() or g2() below in
onclick="" events...

 function g(i) { parent.contents.location = "homecontent.xsql?tab=" + i; }
 function g2(i) { parent.contents.location = i; }

Neither works correctly. Works fine on IE and Netscape 4.x

Comment 4

19 years ago
reopening bug in light of this new info
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

19 years ago
reassigning to default component owner
Assignee: asadotzler → rickg
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: jelwell → janc

Updated

19 years ago
Assignee: rickg → jst

Comment 6

19 years ago
Jst: please take a look.
(Assignee)

Comment 7

19 years ago
Ok, poked around a bit, realized that this html works as it should

<html>
<body>
<p onclick="document.location='http://www.citec.fi'">Click Me</p>
</body>
</html>

but from the comments made by smuench@oracle.com above the problem he's seeing
is that "content" is a property of the window and it referes to the content
are of the window and not the frame named "content", there's a bug on this
problem already, I'm marking this as a dup of that, if someone disagrees then
please reopen this.

*** This bug has been marked as a duplicate of 33650 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 8

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.