KO font sel: Johab* fonts take precedence over user-specified ones

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: jshin, Assigned: erik)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Even though I have the following specifications for fonts to use
rendering Korean text, Mozilla uses fonts with '-johab*' encoding
in seemingly random places.

user_pref("font.name.monospace.ko", "hymjsm2");
user_pref("font.name.sans-serif.ko", "hymjsm2");
user_pref("font.name.serif.ko", "hymjsm2");

On my Linux box, I have both hymjsm2 fonts with KSC5601 GL encoding
and a set of fonts with '-johab*' encoding in addition to other
fonts with KSC 5601 GL encoding. hymjsm2 comes in 6 different sizes
while '-johab*' comes in only 16pixel/point. Despite that hymjsm2
specified in prefs.js has more appropriate matching size, Mozilla
resizes '-johab*' fonts to lead to very ugly rendering result.

  It can be reproduced by viewing any Korean web pages under
Linux/Unix with both '-johab*' fonts and KSC 5601 GL encoded fonts
installed. This bug is present in M15 nightly build and
Netscape 6.0pre1.

Comment 1

19 years ago
erik- how do we handle the case of Japanese font selection ? We need to select a 
JIS x0201 one JIS x0208 and one JIS x0212 font right? It is similar case for 
Korena which the user may want to select a KSC 5601 font and also a JOHAB font.
Assignee: ftang → erik
(Assignee)

Comment 2

19 years ago
I'm working on features for M16. I hope to find time to look into this bug for
M17.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 3

19 years ago
I believe I fixed this bug before the M16 deadline. Jungshik, would you please
verify this?
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M17 → M16

Comment 4

19 years ago
Changed QA contact to blee@netscape.com.
QA Contact: teruko → blee

Updated

19 years ago
Summary: Korean font selection: Johab* fonts take precedence over user-specified ones → KO font sel: Johab* fonts take precedence over user-specified ones

Comment 5

19 years ago
Jungshik, would you please verify this? Currently, I don't have a proper test 
environment for this in my Linux machine.
QA Contact: blee → jshin
(Reporter)

Comment 6

19 years ago
I thought I confirmed that this had been fixed by Erik in bugzilla as
well as in mozilla-i18n list/newsgroup. It turned out I haven't added
my comment here to that effect. This bug WAS fixed (unless it's been
resurrrected since :-)).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.