Dismissing certain repeating events not possible

RESOLVED WORKSFORME

Status

Calendar
Alarms
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Sebastian Schwieger, Unassigned)

Tracking

Details

(Whiteboard: [no l10n impact])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 BonEcho/2.0b2

After creation of a recurring event starting today (but in the past), recurring daily for 5 days with alarms on I get the alarm popup. Pressing Dismiss is not changing anything (popup stays open). Pressing Dismiss all works.
After pressing Dismiss all, the first event is detached from the other recurring events.

Reproducible: Always

Steps to Reproduce:
1.Create an event for today in the past, repeating daily for 5 days. Alarms On
2.Press Dismiss
3.Press Dismiss all

Actual Results:  
Pressing Dismiss does not seem to work
Pressing Dismiss all works.
Afterwards the today-event is detached from the other recurring events.

Expected Results:  
Pressing Dismiss should work.
Double-clicking the first entry should ask me if I want to edit This occurence or all.

If more than one of the recurring events is in the past, pressing Dismiss makes this alarm dialog grow and grow...
(Reporter)

Comment 1

12 years ago
Forgot to mention build ID:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060822 Calendar/0.3a2+

 

Comment 2

12 years ago
I confirm the bug (running in Linux, Lightning build 2006082806)

Updated

12 years ago
Flags: blocking0.3?
(In reply to comment #0)
> After pressing Dismiss all, the first event is detached from the other
> recurring events.

I don't see it as detached. I can change the title on the 2nd recurrence and the original event's title changes to match. What am I missing?

I can confirm the "Dismiss" button that does nothing on
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060827 Calendar/0.3a2+
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> I don't see it as detached. I can change the title on the 2nd recurrence and
> the original event's title changes to match. What am I missing?
> 
You are right, but try to change the title for first reccurence: It is only changed for this.
(Reporter)

Comment 5

12 years ago
I did some more testing:

1. if you press "Dismiss all" without pressing "Dismiss" before, there is no detaching.

2. if you change the title of the detached (first) recurrence it is only changed for this recurrence. Now changing the title of the second recurrence (press "All occurrences") attaches the first recurrence again (title is changed accordingly and double clicking the first event pops up the recurrence dialog again).
(Reporter)

Comment 6

12 years ago
Further testing revealed that events don't need to be created in the past. As soon as an alarm pops up, the bug occurs.

Updated

11 years ago
Flags: blocking0.3? → blocking0.3+
Whiteboard: [no l10n impact]
I can't reproduce this with either the storage or ics provider. Is this worksforme?
(Reporter)

Comment 8

11 years ago
(In reply to comment #7)
> Is this worksforme?

It is even worksforthereporter. Works since 20060901. It might have been bug 348716 or bug 298358 that fixed this bug.

Tested with Sunbird nightlies on Windows and local storage.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Flags: blocking0.3+
You need to log in before you can comment on or make changes to this bug.