Firefox on XULrunner build linker issues

RESOLVED DUPLICATE of bug 345517

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 345517
11 years ago
11 years ago

People

(Reporter: Walter Meinl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060814 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060814 Minefield/3.0a1

While the XULrunner component builds fine, the build fails in the dirprovider component of ff built on top attachment with output to follow.

Reproducible: Always

Steps to Reproduce:
1.Use .mozconfig from bug 299997 build ff ontop of xr
2.xr build no probs
3.ff build fails in dirprovider directory



Expected Results:  
successful build (as was already possible)
(Reporter)

Comment 1

11 years ago
Created attachment 234974 [details]
linker errors

Comment 2

11 years ago
This is a known issue, bug 345517 has patches, but we can't mix frozen linkage and internal linkage so I can't land them while we're still doing Firefox static (non-libxul) builds.
Status: UNCONFIRMED → NEW
Component: XULRunner → Build Config
Ever confirmed: true
Product: Toolkit → Firefox
QA Contact: xulrunner → build.config
(Reporter)

Comment 3

11 years ago
ok after applying the patches from bug345517 I can build it again, marking as duplicate and watching the other bug until resolved ;-)

*** This bug has been marked as a duplicate of 345517 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.