bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

When sorted in descending order, select after delete should move 'up'

VERIFIED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({fixed1.8.1})

Thunderbird2.0
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

12 years ago
This RFE came from Justin.

When sorted in descending order, with newer messages at the top. Delete a message, and we should move selection 'up' to the next most recent message instead of loading the next oldest message.

This is useful for users sorted in descending order when reading new mail. When you start with the oldest unseen message you can hit delete one after another to read your new mail in the order in which it arrived.

We might end up hiding this behavior with a pref. I want to try it out first though before going that path.

Comment 1

12 years ago
Would you rather dupe this to bug 302525 or the other way around?  Note that somebody submitted a patch at that bug just this past January.

Seamonkey bug 185652.  Bug 19625 is the same basic thing, only specifically requesting a preference.  I want the pref, see bug 229220 comment 1 for the reasons why.
(Assignee)

Comment 2

12 years ago
Created attachment 234984 [details] [diff] [review]
work in progress

I haven't thought through the correct behavior yet for deleting multiple items yet, so this is still a work in progress. It leaves the behavior unchanged for the imap delete model.

The JS code that uses this value already checks the validity of the index.
(Assignee)

Comment 3

12 years ago
Created attachment 237838 [details] [diff] [review]
fix hooked up to a pref

I heeded mcow's advice and hooked this up to a pref which can be controlled from about:config.
Attachment #234984 - Attachment is obsolete: true
Attachment #237838 - Flags: superreview?(bienvenu)

Comment 4

12 years ago
Comment on attachment 237838 [details] [diff] [review]
fix hooked up to a pref

would it make sense to cache this value in the view? or is pref retrieval so fast that we don't care?
Attachment #237838 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 5

12 years ago
Checked in with the pref set to false on the branch and trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 6

12 years ago
*** Bug 302525 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
V with TB 3a1 0915, Win2K.

Scott, the patch appears to be to Core, is that correct?
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

12 years ago
yup, seamonkey users can use this pref too.

Comment 9

12 years ago
*** Bug 19625 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
*** Bug 185652 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
I haven't seen this patch in action, but I have my messages sorted with the newest at top (I don't want to see all the old stuff first, cluttering my view). I start reading from the top. 

If I'd want the messages to display from oldest to newest as I delete them ("delete up"), I'd sort from oldest to newest. Having the selection move up just seems odd. Therefore, I think this patch will be more annoying than beneficial.

I hope I'm misunderstanding this bug. Otherwise, I'm hoping for a WONTFIX.

Comment 12

12 years ago
*** Bug 360646 has been marked as a duplicate of this bug. ***

Comment 13

12 years ago
For anyone reading this bug (and don't want to read the patch), to use this feature set the mail.delete_matches_sort_order pref to true. 

Seems it doesn't work with imap mark as deleted model though, will file a follow up bug on that.
OS: Windows XP → All
Hardware: PC → All

Comment 14

12 years ago
*** Bug 360646 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Blocks: 360792

Updated

12 years ago
Duplicate of this bug: 367201

Comment 16

12 years ago
Any plan to make this the default behavior?

Updated

11 years ago
Duplicate of this bug: 263877

Updated

10 years ago
Duplicate of this bug: 222231
Duplicate of this bug: 522420

Comment 20

9 years ago
This fix works for deleting mail, but when you file the email to a folder from the message window toolbar, this doesn't work.  The next message selected will be the next older message below the original email instead of the next newer above the original email.  Is there a setting for that one too?
You need to log in before you can comment on or make changes to this bug.