Use of uninitialized value in pattern match (m//) at editusers.cgi line 270

RESOLVED FIXED in Bugzilla 3.0

Status

()

--
minor
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: bugzilla-mozilla, Assigned: LpSolit)

Tracking

({regression})

2.23
Bugzilla 3.0
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Editing a user gives the following message in the apache error_log:

[Tue Aug 22 23:54:17 2006] [error] [client 127.0.0.1] [Tue Aug 22 23:54:17 2006] editusers.cgi: Use of uninitialized value in pattern match (m//) at /var/www/html/bzcvs2/editusers.cgi line 270., referer: http://localhost/bzcvs2/editusers.cgi?action=edit&userid=2&matchvalue=login_name&groupid=7&grouprestrict=&matchtype=substr&matchstr=some_emailaddress

Quoting that line:
> my $disable_mail = $cgi->param('disable_mail') =~ /^(0|1)$/ ? $1 : 0;

disable_mail is a checkbox, so it is either defined and '1', or it is undef (meaning '0').
(Assignee)

Comment 1

12 years ago
Created attachment 235074 [details] [diff] [review]
patch, v1

The warnings you get are due to bug 100953. This patch does a small cleanup which I always wanted to do.
Assignee: administration → LpSolit
Status: NEW → ASSIGNED
Attachment #235074 - Flags: review?(bugzilla-mozilla)
(Assignee)

Updated

12 years ago
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Updated

12 years ago
Keywords: regression

Comment 2

12 years ago
Comment on attachment 235074 [details] [diff] [review]
patch, v1

Nice job, LpSolit.
Attachment #235074 - Flags: review?(bugzilla-mozilla) → review+
(Assignee)

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 3

12 years ago
Checking in editusers.cgi;
/cvsroot/mozilla/webtools/bugzilla/editusers.cgi,v  <--  editusers.cgi
new revision: 1.133; previous revision: 1.132
done
Checking in template/en/default/admin/users/userdata.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/users/userdata.html.tmpl,v  <--  userdata.html.tmpl
new revision: 1.8; previous revision: 1.7
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.