Closed Bug 349812 Opened 14 years ago Closed 13 years ago

New/Edit task dialog is not timezone sensitive

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jminta, Assigned: jminta)

Details

Attachments

(1 file)

STR:
1.) Create a new task in 1 timezone.
2.) Change Sunbird/Lightning's timezone.
3.) Restart app.
4.) Edit task.

Expected results:
Tasks start/end time converted to the new timezone.

Actual results:
Tasks/start/end time remains the same.
Flags: blocking0.3+
This patch actually converts the time to the desired timezone.  There are no noticable user-facing effects though, because js-date insists on being the bane of my existence.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #235420 - Flags: second-review?(dmose)
Attachment #235420 - Flags: first-review?(mattwillis)
Comment on attachment 235420 [details] [diff] [review]
use getInTimezone

> +        var entryDate, dueDate;
Style nit, but I'd put dueDate above var hasDueDate. Sure it's one more line, but if we have to edit it in the future, it won't hose cvs blame.

r1=lilmatt with that
Attachment #235420 - Flags: first-review?(mattwillis) → first-review+
*** Bug 337191 has been marked as a duplicate of this bug. ***
Whiteboard: [patch in hand][waiting on jminta review][patch doesn't fix entire bug]
Whiteboard: [patch in hand][waiting on jminta review][patch doesn't fix entire bug] → [patch in hand][waiting on dmose review][patch doesn't fix entire bug]
Whiteboard: [patch in hand][waiting on dmose review][patch doesn't fix entire bug] → [patch in hand][waiting on dmose review][patch doesn't fix entire bug][l10n impact]
Comment on attachment 235420 [details] [diff] [review]
use getInTimezone

r=dmose
Attachment #235420 - Flags: second-review?(dmose) → second-review+
Whiteboard: [patch in hand][waiting on dmose review][patch doesn't fix entire bug][l10n impact] → [patch doesn't fix entire bug][needs nit fixed & checkin]
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED

(Note that my "patch doesn't fix entire bug" and "l10n impact" whiteboard entries were me mistaking this bug for another.)
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [patch doesn't fix entire bug][needs nit fixed & checkin]
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060929 Sunbird/0.3
Status: RESOLVED → VERIFIED
Whiteboard: [litmus testcase wanted]
Litmus testcase 3007 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.