Crash on startup with Talkback enabled using XP x64 SP1 [@ msvcrt.dll + 0x48cc3 (0x77be8cc3)]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: wcarloss, Unassigned)

Tracking

({crash, regression})

2.0 Branch
x86
Windows Server 2003
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 07/02, crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1b2) Gecko/20060823 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1b2) Gecko/20060823 BonEcho/2.0b2

I crash every time on startup with today's build using Windows XP x64 SP1 at work.    I have not had any problems at home using XP SP2, so I think it's a 64 bit issue.  When I startup normally, the crash occurs.  If I start up in safe mode, there is no crash.  This even occurs with a brand new profile.

Here are the talkback IDs.  The first one or two are from a new profile, the rest are using my default profile.

TB22415422Z 
TB22415391W 
TB22415263X
TB22415211W
TB22415181G

Reproducible: Always

Updated

12 years ago
Severity: normal → critical
Keywords: crash, regression
Version: unspecified → 2.0 Branch
Bug 345695 comment 6 mentions a crash with a similar stack, using trunk back in 2006-01-01.
Incident ID: 22415422
Stack Signature	msvcrt.dll + 0x48cc3 (0x77be8cc3) da80cd0d
Product ID	Firefox2
Build ID	2006082303
Trigger Time	2006-08-23 07:34:22.0
Platform	Win32
Operating System	Windows NT 5.2 build 3790
Module	msvcrt.dll + (00048cc3)
URL visited	
User Comments	
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
msvcrt.dll + 0x48cc3 (0x77be8cc3)
msvcrt.dll + 0x23148 (0x77bc3148)
msvcrt.dll + 0x27d8d (0x77bc7d8d)
msvcrt.dll + 0x27dd1 (0x77bc7dd1)
PR_GetEnv  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/nsprpub/pr/src/misc/prenv.c, line 82]
0x0300a5f4
nsAutoVoidArray::Clear  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/xpcom/ds/nsVoidArray.cpp, line 685]
0xf98b5708
Summary: Crash on startup using XP x64 SP1 → Crash on startup using XP x64 SP1 [@ msvcrt.dll + 0x48cc3 (0x77be8cc3)]
*** Bug 349873 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

12 years ago
Sorry for submitting the bug twice.  I guess that's what happens when you refresh while it's on the the page right after you submit the bug, instead of the actual bug number page.
(Reporter)

Comment 5

12 years ago
In my normal profile I have the following extensions installed:

Adblock Plus 0.7.1.2
Console2 0.3.5
IE View Lite 1.2.1
Nightly Tester Tools 1.1
Talkback
Update Channel Selector 1.0.1

Since I see the crash with a new profile with no extensions, I can't imagine the problem is extension related.

In case it's a hardware issue, I'm running on an HP x4300 workstation with a dual core 3.2GHz Xeon, an nVidia Quadro FX 1400 with 91 series drivers for xp64, and 8GB of RAM.  That's all the info I can think of so hopefully something will help.
(Reporter)

Comment 6

12 years ago
I believe I figured out the problem; it's Talkback.  I uninstalled Talkback in my branch build and my trunk build and now both start without crashing.  I have all my other extensions enabled in the branch build and it works correctly.  I added the information about Talkback in the summary.  Steve, if you know what component this should be reassigned to can you change it?  
Summary: Crash on startup using XP x64 SP1 [@ msvcrt.dll + 0x48cc3 (0x77be8cc3)] → Crash on startup with Talkback enabled using XP x64 SP1 [@ msvcrt.dll + 0x48cc3 (0x77be8cc3)]
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a6pre) Gecko/2007061504 Minefield/3.0a6pre on xp x64 SP2. 

Weston, do you still see this problem in a latest release like Firefox 2.0.0.4 ?
Whiteboard: CLOSEME - 07/02
(Reporter)

Comment 8

11 years ago
Unfortunately, I no longer have access to an XP x64 machine so I can't confirm that this is fixed.
thanks Weston for your Feedback.

since this is works for me on XP x64 for Trunk/1.8 and 1.8.0 Branch i close this report as works for me. Please feel free to reopen if you can reproduce this crash on a xp x64 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ msvcrt.dll + 0x48cc3 (0x77be8cc3)]
You need to log in before you can comment on or make changes to this bug.