If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The CSS are displayed wrong in my page

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
major
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Eugenia Loli, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m14) Netscape6/6.0b1
BuildID:    Netscape 6 Preview Release 1

My code is using two very small CSS scripts. One for defining the links and one
defining the font. The font specified in <SPAN class="itemtitle"> is not getting
displayed at all.

Reproducible: Always
Steps to Reproduce:
1.Go to www.montal.co.uk
2. You will see that Netscape doesn't use Arial for the news items as IE4/5 does!


Actual Results:  It looks like kack.

Expected Results:  To use this for my news items:

font-family : "Arial, Helvetica, Tahoma";
   font-size : 8pt;
     font-weight : normal;
     color : black;
     letter-spacing: 2;


If you move the <SPAN class="itemtitle"> AFTER the <A HREF="#" class="bb"> tag,
the font is ok, but its not clickable. So, we are talking about the "power of
CSS" onto another, the one overwritting the other. Please fix it...
No DOM problems here, over to style system for evaluation...
Assignee: jst → pierre
Component: DOM Level 2 → Style System
(Assignee)

Comment 2

18 years ago
Per http://www.w3.org/TR/REC-CSS2/fonts.html#propdef-font-family, the code on 
this page is incorrect. The font-family should be defined as
        font-family : Arial, Helvetica, Tahoma;
or
        font-family : "Arial", "Helvetica", "Tahoma";

Closed as Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
Source Code problem not ours. Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.