Being more than one build behind is painful on dialup (get complete update)

RESOLVED DUPLICATE of bug 353182

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 353182
12 years ago
10 years ago

People

(Reporter: Ed Lyczkowski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060822 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060822 BonEcho/2.0b2

Full info here: http://forums.mozillazine.org/viewtopic.php?p=2448643#2448643
On the 19th & 23rd branch nightlies Help > Check for Updates fails to download the correct partial update file and instead starts downloading the full 9 MB .mar file. 
ie. Bon Echo keeps trying to download the 2006082304 - 8.6 MB full .mar instead of the firefox-2.0b2.en-US.linux-i686.partial.2006082204-2006082220.mar and then the firefox-2.0b2.en-US.linux-i686.partial.2006082220-2006082304.mar. 
For a slow dial-up user, like myself, this is painful.

Reproducible: Always

Steps to Reproduce:
1.Whenever a respin has occurred and a normal nightly update follows.
2.
3.

Actual Results:  
Update attempts to download the [b]latest[/b] full .mar file.

Expected Results:  
Update should [b]sequentially[/b] download the partial update files. (Unless they're out of date, like 10 days or so for nightlies.)
As I said on the forum, if you are more than one build behind then you get the complete update. That way you only ever need one restart to have the latest nightly. This change happened in bug 306864, so see that for further motivation.

We could use this bug to gauge how well the new system works. In my opinion it's a  big improvement, both from the number of restarts point of view, and being much more robust when recovering from update outages.
Summary: Partial updates fail. → Being more than one build behind is painful on dialup (get complete update)
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
This is due to nsIncrementalDownload not knowing how to throttle updates - bug 353182. This became a problem after bug 352853 landed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353182
You need to log in before you can comment on or make changes to this bug.