Some compiler flags may be incorrect on Sparc Solaris for freebl

RESOLVED DUPLICATE of bug 349920

Status

defect
RESOLVED DUPLICATE of bug 349920
13 years ago
13 years ago

People

(Reporter: julien.pierre, Assigned: julien.pierre)

Tracking

3.11.2
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

Assignee

Description

13 years ago
The man page for the Sun studio 11 compiler says the following about the -fns option on Sparc :

     -fns[=[no|yes]]
          For SPARC, selects the SPARC nonstandard floating-point
          mode.

[ ... ]
          On SPARC systems, this option is effective only if used
          when compiling the main program.

Since we are using this option in the freebl build, I think it can simply be removed.
Assignee

Comment 1

13 years ago
Assignee: nobody → julien.pierre.bugs
Status: NEW → ASSIGNED
Attachment #235149 - Flags: superreview?(nelson)
Attachment #235149 - Flags: review?
Assignee

Updated

13 years ago
Attachment #235149 - Flags: review? → review?(neil.williams)
Assignee

Comment 2

13 years ago
Comment on attachment 235149 [details] [diff] [review]
Only use optimizer flags if BUILD_OPT is set

I attached this patch to the wrong bug. Sorry.
Attachment #235149 - Attachment is obsolete: true
Attachment #235149 - Flags: superreview?(nelson)
Attachment #235149 - Flags: review?(neil.williams)
Assignee

Comment 3

13 years ago
I'll just take care of removing -fns in the fix for 349920 .

*** This bug has been marked as a duplicate of 349920 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Just out of curiosity, how does one get that man page?
man cc    doesn't.
Assignee

Comment 5

13 years ago
Prepend /opt/SUNWspro/man to your MANPATH (or /wherever/SUNWspro/man if you are using the compiler from a network share).
You need to log in before you can comment on or make changes to this bug.