Ability to override DTD search dir for a single XMLHttpRequest

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
12 years ago
a year ago

People

(Reporter: shurd, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2

Due to Bug 22942, resultXML will not parse extra entities defined in the DTD for the resource.  While having the DTD in the res/dtd/ directory will allow it to work, XPIs such as Newsfox http://newsfox.mozdev.org/ generally can't install a new DTD into res/dtd/ on *nix unless it's being installed as root.  Being able to specify that chrome://newsfox/DTDs/ be searched instead would allow newsfox to include the required DTDs and properly parse entities such as °

Reproducible: Always

Steps to Reproduce:
1. Install newsfox
2. Subscribe to http://bbs.synchro.net/rss.ssjs?channel=syncanno
3. Check feed

Actual Results:  
Undefined element error.

Expected Results:  
° expanded to °
Assignee: xml → nobody
QA Contact: ashshbhatt → xml

Comment 1

a year ago
DTDs are not something we should put more time in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.