Requesr: Parse email addresses that is pasted to "To" field

RESOLVED DUPLICATE of bug 331378

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 331378
12 years ago
12 years ago

People

(Reporter: Tomer Shalev, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060226 Debian/1.5.dfsg+1.5.0.1-3 Firefox/1.5.0.1
Build Identifier: version 1.0.7 (20051017)

When a user copy an email address from a 'spam aware' person who wrote his email in the following manner: "john _at_ doh.com" or "john at doh.com" or even "john at doh dot com", and then paste it to thunderbird, then is should be pasted as john@doh.com rather than the obscured address itself.
Of course there are limitation for trying to guess the real address, but it should be correct in most cases.


Reproducible: Always

Steps to Reproduce:
1. Copy the text "username at hostname.com".
2. Compose a new message.
3. Paste the text in the "To" field.


Actual Results:  
The address "usernamea t hostname.com.mydomain" or something similiar to this would appear.

Expected Results:  
The address "username@hostname.com" would appear.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 331378 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.