Pages are reloaded too often: POSTDATA, save page as, view page source, moving tabs

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: michael-bugzilla-firefox, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Firefox reloads pages too often.

Previous versions would force a reload on "Save page as", or when moving a tab between windows (but not when re-ordering tabs in a given window). However, I could get "Save page as" functionality by first viewing the page source, and then saving from there.

Today, while paying my credit card bill, I found that "Save page as" will force a reload.

This means that there is no way to save the page that I am looking at. None. Any attempt to do so will ignore what's in front of me, and try to fetch a fresh copy. But to my bank, that looks like a second payment and is turned down, returning a different page.


Reproducible: Always

Steps to Reproduce:
1. Visit a page.
2. Try to view the source, or move the tab to another window, or save the page
3. This is easier to see if the page is a POST instead of a GET

Actual Results:  
Firefox wants to reload the page, and resubmit POSTDATA

Expected Results:  

Expected results:
Any attempt to work with a page that firefox has should work with the page that firefox has, not just with the URL / fetching information.

Moving a tab between windows should move a tab as it looks now.
Save page as should save what I am looking at now.
View source should show me the source of what I am looking at now.

Refetching -- even on GET's -- can return different data (just think of discussion forums.)


Marking as "Major" because:
Cannot save pages. Cannot store a receipt of payment.

Extensions loaded: 
DOM inspector 1.8.0.6
Talkback 1.5.0.6
Greasemonkey 0.6.5.20060727
Adblock v5 d3 nightly 43
Coralize 0.7
VideoDownloader 1.0
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

11 years ago
I just paid my credit card today. It is still there.

A page that is marked as "do not cache" is treated by firefox as "I must reload this page every time. I will not keep my copy of the page around at all".

I cannot view source on the page.
I cannot "save as".

This hurts, as I said, things like payment receipts, which cannot be saved in the form that I see on screen. I can, oddly, print them (on my mac I can print to a PDF and save that.)
Whiteboard: CLOSEME 07/05 → CLOSEME 07/05. Nope, still there
(Reporter)

Comment 3

11 years ago
Created attachment 271216 [details]
PDF from printing my payment receipt. Note that all the account- and payment- specific information is missing.

Up until now, I've been able to print a PDF copy of my payment receipt (for the last few months). Today that failed -- the printing copy, on page one, has none of the account information, payment information, confirmation number, etc. All missing.

Updated

11 years ago
Whiteboard: CLOSEME 07/05. Nope, still there
Version: 1.5.0.x Branch → 2.0 Branch
Is this problem reproducable with a new firefox profile?
- http://kb.mozillazine.org/Profile_manager
(Do not delete your existing profile)

Are you able to test with a trunk build?
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Note to self: This bug might want to block bug 288462

Comment 6

10 years ago
This still happens in firefox 3. At least with view source code. It asks the server for the source code, instead of using the already downloaded one

Comment 7

10 years ago
This is in 3.1b3pre as well - this is a real problem for development. Viewing source on my php scripts shows me the source of the script as if I hadn't posted data. I would expect view source to show me the source currently being displayed on the page.

Comment 8

10 years ago
Show be fixed with bug #469302
https://bugzilla.mozilla.org/show_bug.cgi?id=469302

Comment 9

10 years ago
I've experienced this bug several times and just today I have this bug with firefox 3.0.7 . Restarting firefox usually helps for me, annoying though since I have like 30 tabs I want to keep.. will take forever to reload.. sigh

Comment 10

10 years ago
Created attachment 367953 [details]
Session is not expired but source code shows expired session source code

Comment 11

9 years ago
This bug was reported using a version of Firefox that security and stability updates are no longer provided for.  All users are strongly encouraged to upgrade to Firefox 3 by selecting 'Check for Updates' in the Help menu or by going to http://www.mozilla.com/en-US/firefox/firefox.html

If you can no longer reproduce this bug using the latest Firefox 3.0.x version, please change the status of this bug to 'RESOLVED' 'WORKSFORME'.

If you can still reproduce this bug, please provide additional details to help resolve this issue.

Comment 12

9 years ago
seems to work good on:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090725 Minefield/3.6a1pre
(Reporter)

Comment 13

9 years ago
Tested at the beginning of September. I was able to pay my credit card bill, and save a copy of the payment confirmation page both from the normal webpage view, and from the view source view.

Oddly, saving from the normal webpage view did trigger a download in the download log, but that turned out to be a valid copy, not a complaint from the website.

So now changed to Resolved, WorksForMe. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

9 years ago
Silly me. Tested with FF 3.0.12, Mac os 10.5.7.
(Reporter)

Comment 15

9 years ago
September? Make that [b]August[/b] 1st :-).
You need to log in before you can comment on or make changes to this bug.