If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

session restore does not restore download in progress

RESOLVED DUPLICATE of bug 349971

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 349971
11 years ago
11 years ago

People

(Reporter: juanb, Unassigned)

Tracking

2.0 Branch
Firefox 2
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

The download manager, and whatever download in progress, is not session restored.

To recreate:
1. Launch Firefox and open several windows.
2. Start a download from here: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
3. Kill Firefox using the Activity Monitor to trigger session restore
4. Relaunch Firefox and select "Restore Session"

Expected: All windows and the Downloads manager reappear, and the download restarts.

Actual: Downloads manager doesn't reappear, nor is the download restarted.

If you open the Download manager, you'll see that the download in progress is still there, but you only have the option to Pause or Cancel, and its properties indicate the download is Finished, but that's not the case.

This also happens in WinXP.

*** This bug has been marked as a duplicate of 349971 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.