tr_install.pl falls on its face. Bugzilla patching fails

RESOLVED DUPLICATE of bug 346366

Status

Testopia
General
--
major
RESOLVED DUPLICATE of bug 346366
12 years ago
12 years ago

People

(Reporter: Jim Lovell, Assigned: Greg Hendricks)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060406 Firefox/1.5.0.4 (Debian-1.5.dfsg+1.5.0.4-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060406 Firefox/1.5.0.4 (Debian-1.5.dfsg+1.5.0.4-1)

tr_install.pl file finds the correct patch but fails to patch.  Docs suggest manual patch, but don't list the file to patch.

Reproducible: Always

Steps to Reproduce:
1. run tr_install.pl
2. grind teeth


Actual Results:  
Now installing Testopia ...

Patching Bugzilla's files ...

No patch file especified, trying to determine the right one to use ...

Bugzilla version 2.22-debian1 detected.
Patch file chosen: patch-2.22

Now patching ...

The text leading up to this was:
--------------------------
|diff -u -r workspace/bmo2-20-2-tp10/enter_bug.cgi temp/bbmo-2.20.2-clean/enter_bug.cgi
|--- workspace/bmo2-20-2-tp10/enter_bug.cgi      2005-10-23 15:50:34.000000000 -0600
|+++ temp/bbmo-2.20.2-clean/enter_bug.cgi        2006-06-01 16:54:24.000000000 -0600
--------------------------
File to patch: 
Skip this patch? [y] 
1 out of 1 hunk ignored
The text leading up to this was:
--------------------------
|diff -u -r workspace/bmo2-20-2-tp10/post_bug.cgi temp/bbmo-2.20.2-clean/post_bug.cgi
|--- workspace/bmo2-20-2-tp10/post_bug.cgi       2006-01-08 12:54:34.000000000 -0700
|+++ temp/bbmo-2.20.2-clean/post_bug.cgi 2006-06-01 16:54:24.000000000 -0600
--------------------------
File to patch: 
Skip this patch? [y] 
2 out of 2 hunks ignored
The text leading up to this was:
--------------------------
|diff -u -r workspace/bmo2-20-2-tp10/template/en/default/bug/create/created.html.tmpl temp/bbmo-2.20.2-clean/template/en/default/bug/create/created.html.tmpl
|--- workspace/bmo2-20-2-tp10/template/en/default/bug/create/created.html.tmpl   2005-07-27 14:56:09.000000000 -0600
|+++ temp/bbmo-2.20.2-clean/template/en/default/bug/create/created.html.tmpl     2006-06-01 16:55:06.000000000 -0600
--------------------------
File to patch: 
Skip this patch? [y] 
1 out of 1 hunk ignored

*** Patching of Bugzilla's files failed. None of your files has been modified.

Some possible reasons:

- Your Bugzilla installation has been modified from the original.
> Please scroll up and see if the patch command output you can see above gives you any clue. Consult Testopia's installation manual and get ready for some manual patching.

- The patch file used was the wrong version.
> If you didn't especify the patch file to use, maybe this installation script picked up the wrong one. In this case, please, check out in the testopia directory the list of available patch files (files named as patch*) and run the install script especifying the file to use, according to the Bugzilla's version you are using. For instance, if you are using Bugzilla version 2.19.2, this is the command line you should use:
    tr_install.pl testopia/patch-2.19.2
> If you did in fact especify a patch file on the command line, please, double-check your Bugzilla version and the patch file you used and try again.

- Testopia is not prepared to work with this particular version of Bugzilla.
> Please, check the documentation. Verify that this version of Bugzilla is supported.

If you still have problems, please, check out Testopia's installation manual again and, if nothing helps, report the problem to Testopia sourceforge forum at http://sourceforge.net/projects/testopia.
<h1>Software error:</h1>
<pre>
Install failed. See details above.
</pre>
<p>
For help, please send mail to this site's webmaster, giving this error message 
and the time and date of the error.



Expected Results:  
bugzilla patches and continues with install

Bugzilla 2.22 installed via apt; latest testopia build
(Reporter)

Updated

12 years ago
Version: unspecified → 1.0
(Assignee)

Comment 1

12 years ago
Patch on bug 346366 fixes the problem

*** This bug has been marked as a duplicate of 346366 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.