bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

"Open Location..." behavior inconsistant when opening new window

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: Reid Beels, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When a window is open and File->Open Location... is invoked (either via the menu or the keyboard) focus is given to the address bar.

When no window is open and this command is invoked, a new window opens and shows the "Open Web Location" dialog. It seems to me that open location should behave in this context in exactly the same way as the new window command.

Reproducible: Always

Steps to Reproduce:
1. Close all windows
2. Invoke File->Open Location...
3.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

11 years ago
Issue still exists. 

1. Launch FF
2. File->Open Location... 
3. note result
4. Close window
5. File->Open Location...
6. Note different result.
And does this problem still occur if you make a new firefox profile?
- http://kb.mozillazine.org/Profile_manager
(Note: Do not delete your existing profile!)
(Reporter)

Comment 4

11 years ago
No, making a new profile seems to fix it.
If it works in a new profile then the strange behaviour you see it probably due to an extension (or maybe firefox setting). You should try disabling your extensions one by one until the problem goes away, and then let us know what the cause was if you could.
(Reporter)

Comment 6

11 years ago
Looks like Firebug 1.0.5 is triggering it.
OK because this is caused by a regression and is not Firefox's default behaviour, I am resolving this bug as INVALID. You need to email the extension author and get them to have a look at the problem. Thanks for the troubleshooting!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Whiteboard: CLOSEME 07/05
Version: 1.5.0.x Branch → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.