Cairo alpha blends image edges with background before upsizing

VERIFIED DUPLICATE of bug 324698

Status

()

Core
Graphics
VERIFIED DUPLICATE of bug 324698
12 years ago
12 years ago

People

(Reporter: Norman Rasmussen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

545 bytes, application/octet-stream
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060824 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060824 SeaMonkey/1.5a

If a developer tries to use a really small image to 'fill' a large area, by forcing its size to be larger than it is.  Then it's edges are 'blended' with the background color, making the seamless images look terrible.

Reproducible: Always

Steps to Reproduce:
see attached test case
Actual Results:  
blended areas are seen

Expected Results:  
should render single color
(Reporter)

Comment 1

12 years ago
Created attachment 235310 [details]
testcase 1
(Reporter)

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 324698 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.