tags migrated from labels don't stick

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: asa, Unassigned)

Tracking

(Blocks: 1 bug, {qawanted})

qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs protocol log])

(Reporter)

Description

12 years ago
If I tag a message with a tag that used to be a label, it doesn't stick when I leave the message folder and come back. If I tag a message with a tag that was created using the new tag feature, the tag does stick.

Updated

12 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird2.0
WFM on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061206 Thunderbird/2.0b1 ID:2006120603

Comment 2

12 years ago
Asa: IMAP or POP?

Comment 3

12 years ago
I'm having what appears to be the same problem, with Thunderbird 2.0.0.0 (20070326).  This is with IMAP folders; I access the same IMAP folders from two different TB instances on different computers.  In the past I used labels and everything worked fine; upon migrating to TB2.0, I'm having trouble getting tags to stick.

I've tried deleting all the tags migrated from labels and re-creating them, but it doesn't seem to have made a difference.  Right now I can tag several messages, go to another folder, and then back, and the tags have disappeared.  I can also tag messages in a virtual folder, and then go to the folder itself, and the tags are there, but if I go back to the virtual folder, the tags have disappeared in both places.

Let me know if there's any other information I can provide about this.

Comment 4

12 years ago
My comments are essentially identical to Comment #3.  I have an AOL email address and access my messages via IMAP.  Prior to 2.0 tags worked fine.  However, in version 2.0.0.4 (20070604) tags disappear if I leave the folder and then come back.

Comment 5

11 years ago
Daniel, Mike,

what mail server software and version?
can be obtained via
  telnet <smtp address> 25

Comment 6

11 years ago
I apologize, but when I type in "telnet smtpl.aol.com 25" it simply says "Trying 205.188.159.148..." and hangs.  What am I doing wrong?  Also, could you tell why am I looking for smtp info when the issue is more imap related?  Just curious. 

Comment 7

11 years ago
smtp can return on your mail server. i get a blank screen  telnet to smtp.aol.com, which means it connected but I don't get an information response. 

what happens if you try the the standard mail port?

Comment 8

11 years ago
Asa, re: comment 2. And do you still see this problem?

Comment 9

11 years ago
My IMAP service is from AOL.  My SMTP service is from my DSL provider.  How would I try the standard mail port in this circumstance?
Mike: aol smtp uses port 587, so try "telnet smtp.aol.com 587"

Comment 11

11 years ago
When I type in "telnet smtp.aol.com 587" it responds with "220 ciaaol-d09.mx.aol.com ESMTP mail_cia_aol-d09.7; Sat, 01 Sep. 2007 17:22:06 -400".  I do not know the SMTP command which would tell me the mail software and version.  I tried to find the answer to that last question by have been unsuccessful.  Can you guide me to the next step?
Looks like it's their own software, named "mail_cia_aol-d09.7". Or there's where it usually would say what software it is.

Asa and Daniel Pryden: are your reports also for the AOL server? 

Comment 13

11 years ago
It's been a while since I looked into this. In my case, though, it's not AOL, it's whatever server Everyone.net uses for IMAP.  I've got multiple instances of Thunderbird pointed at the same IMAP folders; when I upgraded them to Thunderbird 2 then at least one of them lost the ability to set tags on messages -- the tags just disappear as soon a I switch folders.  I'm clumsily working around it with stars, but I haven't checked the functionality in a while. Is there something more specific I can get you?

Comment 15

11 years ago
I'm sorry about the long time since I posted anything to this bug.  I just tried to reproduce with a brand new profile and I got the same problem, which indicates to me that the migration from labels isn't the problem (at least in my case). I've attached an IMAP log to bug 370440, which seems to be the specific problem in my case. If anyone thinks it would be more useful here, I can attach the log to this bug as well.
Duplicate of this bug: 383587
Blocks: 432710
Assignee: mscott → nobody
Status: ASSIGNED → NEW

Updated

10 years ago
Flags: wanted-thunderbird3?
Target Milestone: Thunderbird2.0 → ---

Comment 17

9 years ago
Joe, rsx, do you recall seeing this for people going to 2.0 from 1.x?

needs imap or pop protocol log
https://wiki.mozilla.org/MailNews:Logging
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: qawanted
Whiteboard: [needs protocol log]
Version: unspecified → 2.0

Comment 18

9 years ago
Confirm! Very annoying bug and there's nothing you can do to fix it - even if you let the main window stay on top, tags dissapear. Sometimes they dissapear after a new message has arrived, sometimes after you minimize TB to tray, sometimes after removing focus from TB's window... I reported it just after 3.x version has arrived. My system - Win7 x64, ThunderBird 3.0.4

Comment 19

8 years ago
Sibin....
> needs imap:5 or pop3:5 protocol log
https://wiki.mozilla.org/MailNews:Logging

Daneil's issue was fixed by bug 370440.
And There's not enough information from Asa to determine his issue.
=> incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.