{inc} 'clear' breaks when clicking links

RESOLVED FIXED

Status

()

Core
Layout: Floats
RESOLVED FIXED
12 years ago
5 years ago

People

(Reporter: mdew, Assigned: roc)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060823 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060823 Firefox/2.0b1

When clicking on the links, you'll find the links will move to the right

Reproducible: Always

Steps to Reproduce:
1. Click on each link
2. Watch the other link move to the right.
3.

Actual Results:  
the following link will move to the right

Expected Results:  
It shouldn't move

This doesn't happen in either Opera or IE
(Reporter)

Comment 1

12 years ago
Created attachment 235351 [details]
heres a sample of what happens

Comment 2

12 years ago
On the trunk there's no horizontal movement.  There's is some up and down movement though.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060824 Minefield/3.0a1 ID:2006082404 [cairo]

Comment 3

12 years ago
There is no problem with the testcase in Fx 1.0.7.
Keywords: regression, testcase
I see it in SeaMonkey trunk. I think it's reported already but I'm not sure.
Component: General → Layout: Floats
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.floats
Summary: align=left doesnt stay left → {incr} align=left doesnt stay left
Whiteboard: DUPEME
Version: unspecified → Trunk
Summary: {incr} align=left doesnt stay left → {inc} align=left doesnt stay left
I can see the bug too on current trunk build and on a reflow branch build. Marking new (if a similar bug can be found, this can still be duped to that).
Blocks: 261196
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

12 years ago
This bug also occurs with align=right too
Summary: {inc} align=left doesnt stay left → {inc} 'clear' breaks when clicking links
I see the bug but we need a minimized testcase here.
Created attachment 235549 [details]
more minimised testcase
Created attachment 239267 [details] [diff] [review]
fix

Simple bug ... we record inlineFloatBreakType from a line ending with <BR CLEAR=...> so we can apply it to the next line. But if that line is the last line, we weren't doing anything with it.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #239267 - Flags: superreview?(dbaron)
Attachment #239267 - Flags: review?(dbaron)
Attachment #239267 - Flags: superreview?(dbaron)
Attachment #239267 - Flags: superreview+
Attachment #239267 - Flags: review?(dbaron)
Attachment #239267 - Flags: review+
Checked in. Thanks for the testcase, Martijn!
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
When I checked this in, I also checked in a patch from bug 312963. Which is OK since it was about to go in anyway.

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.