Closing last tab does not close window.

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Fredrik Henrysson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060824 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060824 Minefield/3.0a1

When the preference "Always show the tab bar" is enabled. Closing the last tab doesn't close the window, it just clears the content of the tab. 

Reproducible: Always

Steps to Reproduce:
1. Enable "Always show the tab bar"
2. Close the last tab.


Actual Results:  
The content of the tab was cleared.

Expected Results:  
The window holding this tab should be closed.
Yes, that's by design. See interminable years of discussion in bug 236721, and the linked wiki page, and linked and unlinked forum threads.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.