Suggest query should contain hl=ja param in the ja/ja-JP-mac Google search plug-in

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: kohei, Assigned: mozilla758+bmo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: google suggest uses hl=ja param, the only distinct corpus)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: N/A

Google Suggest now supports two languages - English and Japanese.

http://www.google.com/webhp?complete=1&hl=en
http://www.google.co.jp/webhp?complete=1&hl=ja

Our ja/ja-JP-mac Google search plug-in should use the latter, of course, so we have to add 'hl=ja' param in the suggest query.

Example:
http://suggestqueries.google.com/complete/search?output=firefox&client=firefox&qu=Fire
http://suggestqueries.google.com/complete/search?output=firefox&client=firefox&qu=Fire&hl=ja


Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 235398 [details] [diff] [review]
patch
(Reporter)

Updated

12 years ago
Blocks: 348024
(Reporter)

Comment 2

12 years ago
We need hl=ja param because suggestqueries.google.com seems not to automatically detect the Accept-Language HTTP header.

Comment 3

12 years ago
Mic, Phil, could you try to get this confirmed by Google?

I'm pretty sure that if this turns out to be the case, we would want this in the en-US plugin to be shared across locales.

Comment 4

12 years ago
Make things clear:

When we specify language with hl=ja:
  if input is alphabet: Japanese suggestion will be returned
  if input is japanese: Japanese suggestion will be returned
When we don't specify language:
  if input is alphabet: English  suggestion will be returned :(
  if input is japanese: Japanese suggestion will be returned

That is, without hl paramater, we canno get Japanese suggestion when we type only alphabet. So, we should use hl=ja.
Af far as we test, only en and ja are valid for hl parameter for Google Suggest. We think that's because Google is supporting only en and ja so far.

c.f only english and japanese service are in Google lab page
http://labs.google.com/

If other languages also supported we should include hl parameter in en-US plugin and share it. If not, only ja should have different plugin with hl parameter, I think.

Comment 5

12 years ago
(In reply to comment #3)
> Mic, Phil, could you try to get this confirmed by Google?
> 
> I'm pretty sure that if this turns out to be the case, we would want this in
> the en-US plugin to be shared across locales.

Yeah, I'm getting in touch with Brian Rakowski.  But if you combine this with the fact that Google seems to be very strict about which locales it accepts, it looks like a complete pain in the ass.

Updated

12 years ago
Whiteboard: bizdev-google suggest hl=ja param?

Updated

12 years ago
Whiteboard: bizdev-google suggest hl=ja param? → [needs-mic]bizdev-google suggest hl=ja param?

Comment 6

12 years ago
i have pinged google again to get further information, still pending
best
mic

Comment 7

12 years ago
hi all
i received a response for google, but i'm not sure it's helpful, and i quote:
"we continue to advise including an HL parameter for best results.  We will probably add some best-guess country-->language detection to Suggest in the future, but I don't have a clear timeline for that."
is there another way i can be helpful here?
mic

Comment 8

12 years ago
need some further input here, is there anything i can do to be helpful? if not can we resolve this bug as "fixed" or "worksforme" ?
best
mic

Comment 9

12 years ago
Current status is:
  Japanese suggestion should be returned for ja/ja-JP-mac Firefox users 
  only English suggestion will be returned without hl=ja
  country-->language detection is not implemented yet
  Google don't have clear timeline to implement country-->language detection
  only hl=ja works and other value  (e.g. hl=fr) will not effects (as far as we test in japan)

Search suggest is important improvement of Firefox 2.0 and we must support Japanese suggestion correctlly.
AFAIK it seems that hl parameter will be the solution for ja and only for ja so far. I think we should make Japanese specific search plugin for ja/ja-JP-mac which includes hl parameter. It's the easiest answer for this.
# all other locales will use same plugin as en-US

When other parameter like hl=fr will be valid, then we can add hl paramater in en-US (all locale) plugin or we can just make fr specific plugin too.

If you agree with this, please give approval to use ja specific search plugin.
# I'll request approval against the patch 235398

If you don't agree and think we should include hl parameter for all locale even if it make effects only japanese, please reject request of approval and write patch.

Updated

12 years ago
Attachment #235398 - Flags: approval-l10n?

Comment 10

12 years ago
Comment on attachment 235398 [details] [diff] [review]
patch

Yes, let's go with google-jp.xml.
Attachment #235398 - Flags: approval-l10n? → approval-l10n+

Comment 11

12 years ago
Axel,
based on this recent exchange can we close this bug? is the information now clear?
if so, please go ahead and close this bug as from a BD perspective this has been reviewed and I think we're good to go.
best
mic
I confirmed that we can get Japanese suggestion with latest l10n nightly.
 -> RESOLVED FIXED

In case other languages suggestion will be supported by google, IMHO we should file separate bug for the languages or bug to change en-US one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 13

12 years ago
I filed bug 352672 on maybe adding hl=language generically, for japanese and 2.0, we're done.
Status: RESOLVED → VERIFIED
Whiteboard: [needs-mic]bizdev-google suggest hl=ja param? → google suggest uses hl=ja param, the only distinct corpus
You need to log in before you can comment on or make changes to this bug.