NPN_GetURLNotify on uncached URL when offline does nothing

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: William Bardwell, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-05])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If a plugin calls NPN_GetURLNotify on a URL which has not been loaded before, or which is uncached (because previous loads returned a 404 for example), when offline none of the callback functions ever get called, including NPP_URLNotify or NewStream or anything else.
It should immediately call NPP_URLNotify with NPRES_NETWORK_ERR, since it
can't load stuff while 'working offline' that isn't already in the cache.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
The patch that I provided for [Bug 319371] seems to fix this as well.
Depends on: 319371

Comment 2

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a4) Gecko/20100407 MozillaDeveloperPreview/3.7a4
Please update if you are able to still reproduce with the latest nightly build  ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Whiteboard: [closeme 2010-05-05]
(Reporter)

Comment 3

8 years ago
It looks like the fix for Bug 319371 when in and fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.