Location bar shows about:blank after toolbar customization

VERIFIED FIXED

Status

()

Firefox
Toolbars and Customization
--
trivial
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: mwu, Assigned: mwu)

Tracking

({fixed1.8.1, polish})

Trunk
fixed1.8.1, polish
Points:
---
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

12 years ago
If the user has about:blank open and then customizes his/her toolbars, the location bar will show about:blank immediately afterwards. The location bar should remain empty, however.
(Assignee)

Comment 1

12 years ago
Created attachment 235989 [details] [diff] [review]
Leave urlbar blank for about:blank
Assignee: nobody → michael.wu
Status: NEW → ASSIGNED
Attachment #235989 - Flags: review?(bugs.mano)
Comment on attachment 235989 [details] [diff] [review]
Leave urlbar blank for about:blank

I would rather do
gURLBar.value = url == "about:blank" ? "" : url;

r=mano with that fixed.
Attachment #235989 - Flags: review?(bugs.mano) → review+
(Assignee)

Comment 3

11 years ago
Created attachment 236117 [details] [diff] [review]
As checked in

Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.701; previous revision: 1.700
done
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

11 years ago
Comment on attachment 236117 [details] [diff] [review]
As checked in

This patch is minimal risk, and fairly obvious.
Attachment #236117 - Flags: approval1.8.1?
Comment on attachment 236117 [details] [diff] [review]
As checked in

a=beltzner on behalf of 181drivers
Attachment #236117 - Flags: approval1.8.1? → approval1.8.1+
*** Bug 256460 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

11 years ago
Branch checkin:
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.479.2.198; previous revision: 1.479.2.197
done
Keywords: fixed1.8.1

Comment 8

11 years ago
If you compare this patch with the code at http://tinyurl.com/rbyvl , does the call to SetPageProxyState really not do any harm here while it does in handleURLBarRevert?
Keywords: fixed1.8.1
Keywords: fixed1.8.1
Flags: in-litmus?
http://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=4521

in-litmus+
Flags: in-litmus? → in-litmus+
Verified FIXED using

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007102704 Minefield/3.0a9pre

and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102721 Minefield/3.0a9pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.