"how Firefox protects you" link in phishing protection does nothing

VERIFIED FIXED in Firefox 2

Status

()

Toolkit
Safe Browsing
VERIFIED FIXED
12 years ago
4 years ago

People

(Reporter: juanb, Unassigned)

Tracking

2.0 Branch
Firefox 2
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

The phishing protection warning dialog has a link "how Firefox protects you" that isn't doing anything.

To reproduce:
1. Assuming you have phishing protection enabled, go to sample phishing page: http://www.google.com/tools/firefox/safebrowsing/phish-o-rama.html
2. When the warning dialog comes up click on the link "how Firefox protects you". You may have to click "Read More" first if this is the first time you trigger the warning.

Expected: You should be taken to a page that explains "how Firefox protects you"

Actual: You click on the link and nothing happens.

Also happens in WinXP, and it very likely happens in linux, too.
(Reporter)

Updated

12 years ago
Flags: blocking-firefox2?

Comment 1

12 years ago
This is a regression caused by bug 348076.  Looks like it's already fixed: http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/app/profile&command=DIFF_FRAMESET&file=firefox.js&rev1=1.153&rev2=1.154&root=/cvsroot
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
This is a known issue for Firefox 2.0b2, but it's fixed for Firefox 2.
Flags: blocking-firefox2?

Comment 3

12 years ago
verified in RC2
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.