Closed Bug 350277 Opened 16 years ago Closed 16 years ago

Print > Save as .PDF - should give page title as default filename

Categories

(Camino Graveyard :: Printing, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 303547

People

(Reporter: mail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060821 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060821 Camino/1.2+

Printing and then choosing to save the printout as a PDF currently gives a default filename of ".pdf"

This makes it difficult for users to quickly save pages as PDFs for future reference.

The default filename should be "<title>.pdf". This would replicate Firefox's behaviour in the same situation.

Reproducible: Always

Steps to Reproduce:
1. File > Print > Save as .PDF
2. Be frustrated at having to choose and type in a descriptive filename
3. Decide to use Firefox any time you want to save a page as a PDF

Actual Results:  
The default filename given for all pages saved as PDFs is ".pdf"

Expected Results:  
The default filename for all pages saved as PDFs should be "<title>.pdf"

If saved a file as a PDF now (while entering this bug), I should be offered to save "Enter a Bug.pdf"

Mac versions of Firefox (inc. 1.5.x and 2.0a) give the page title as the default filename for all pages saved as PDFs. Implementing this behaviour in Camino should be simple and uncontroversial.
I'm pretty sure this is a dupe of bug 303547.

cl

*** This bug has been marked as a duplicate of 303547 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.