Negative window possition when opening full-size windows

VERIFIED INCOMPLETE

Status

()

VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: terje.rosenlund, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060822 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060822 Minefield/3.0a1

When a full-blown window is opened the :
window.screenX = -4
window.screenY = -4

(same in all screen-resolutions)

Reproducible: Always

Steps to Reproduce:
1.Open Error-console in full-size window
2.evaluate alert(window.screenX) and alert(window.screenY)


Actual Results:  
window.screenX = -4
window.screenY = -4

Expected Results:  
window.screenX = 1
window.screenY = 1
(Reporter)

Comment 1

12 years ago
- Setting screenX or screenY causes window to be resized to its previously redused size
- In order to see the whole window window.screenX must be 1 while window.screenY must be 0

Updated

12 years ago
Version: unspecified → Trunk
Reporter, are you still seeing this issue with Firefox 3.6.8 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
(Reporter)

Comment 3

8 years ago
This report actually contains 2 issues (should have been 2 reports)

Issue 1:

Twice as bad as before (same when running in safe mode or not):

Steps to Reproduce:
1.Open Error-console, maximize window
2.evaluate alert(window.screenX) and alert(window.screenY)

Actual Results:  
window.screenX = -8
window.screenY = -8

Issue 2 (regarding setting screenX and/or screenY):

Setting theese attributes has no effect in safe-mode (disabled) but now works as expected in normal mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; nb-NO; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Created a new profile and tested as requested - same result

window.screenX = -8
window.screenY = -8

I dont mind checking this but ain't it more easy for the developer to check this himself? Very easy to open the error-window, maximize size and evaluate
alert(window.screenX) and alert(window.screenY) in the code-field
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED

Comment 6

7 years ago
This is actually normal behavior on windows: Any maximized window is moved to negative coordinates and has its width/height (including border/padding) set to the resolution + (border + padding) * 2 to hide the fact that those elements are not removed. If you're bothered by this, you're just going to have to get over it; this hasn't changed since '95 at the least, and possibly traces back to the first window-managing GUI created.
You need to log in before you can comment on or make changes to this bug.