No search engine choices for Mac sidepanel search

VERIFIED WORKSFORME

Status

SeaMonkey
Search
P3
major
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: Claudius Gayle, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [NEED INF0])

(Reporter)

Description

19 years ago
***Overview Description: 

	There are no search engine choices in the mac sidepanel search.

***Steps to Reproduce: 

1) Open up the search sidepanel

2) Click on the within 'All Engines' dropdown.


***Actual Results: 

	THe only thing in the dropdown are the words 'All Engines' with a checkmark and a separator.

***Expected Results: 

	Some category choices and and engine choices corresponding to each below.

***Build Date & Platform Bug Found: 

	MAC ONLY with 2000040709 builds.

***Additional Information:

	i just realized this is two bugs. The dropdown is empty save the 'All Engines choice' AND the are no engines listed 
whatsoever.
Needless to say search is useless like this.
(Reporter)

Comment 1

19 years ago
by the way, this combined with bug 34490 menas we have NO search functionality on the Mac, cc leger.

Comment 2

19 years ago
This works fine for me with a current build on the Mac.

Although, I'm running Mac OS 9.  Do you see this problem only with Mac OS 8.6 
(and not 9) ?
(Reporter)

Comment 3

19 years ago
nah I just checked. We see this on OS 8.6 and 9 machines. Are you 'looking' at 
opt bits? Maybe this is a build packaging issue since it's just the Mac and it's 
been like this for a while now.
(Reporter)

Comment 4

19 years ago
I was just looking at bug 34490 and I feel pretty sure this is a debug vs. opt issue. I checked all the moz vs. ns permutations as 
well.

please look into this. we have NO SEARCH functionality whatsoever on Mac builds. nominating for nsbeta2
Keywords: nsbeta2

Comment 5

19 years ago
I checked in some changes last night regarding where search files are placed... 
so please re-test this bug with Monday's build.

Comment 6

19 years ago
claudius - PDT needs to know if this happens with latest Mac...once you get a 
good buil :-)
Whiteboard: [NEED INF0]
(Reporter)

Comment 7

19 years ago
I tried this again with the 2000042417 build and:

There are now category choices in the pulldown (Web, jobs, music, etc.) but there are still no search engine choices.

For an extra twist, each time I started up the browser and went to the search panel for the first time I was presented with a list of 
all the other sherlock files that reside on my mac but none of the Netscape provided search engine/sherlock files. This list then 
disappeared and became unrecoverable if I swicthced the category dropdown.

In short, (for PDT consumption) the behavior has changed but there is still no sidepanel* searching on the Mac.

*this may have fixed bug 34490 for url searches as they kinda work (but still with no results in the sidepanel).

Comment 8

19 years ago
WORKSFORME now.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
There is no longer a within all engines dropdown on build 2000082409. 
Marking verified worksforme.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.