Closed Bug 350327 Opened 13 years ago Closed 13 years ago

Manually removing profile folder causes FF to fail to open

Categories

(Toolkit :: Startup and Profile System, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: FirasE, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If you go into the %appdata%\Mozilla\Firefox\Profiles folder and erase/rename the folder name corresponding to the default profile, and then try to start FF, you get the following message:

"Firefox is already running, but is not responding. To open a new window..."

Checking TaskMan, Firefox is not running. If an end user accidentaly deletes his profile folder, for whatever reason, Firefox doesn't fail gracefully. It should automatically create a new default profile.

Reproducible: Always

Steps to Reproduce:
1. Go into %appdata%\Mozilla\Firefox\Profiles
2. Delete or rename the default profile's folder
3. Try to start Firefox

Actual Results:  
The error message ""Firefox is already running, but is not responding. To open a new window..." appears.

Expected Results:  
A new default profile should have been created.
Component: General → Startup and Profile System
QA Contact: general → startup

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.